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1 INTRODUCTION  
weldMARK® is a powerful and flexible laser processing software suite. The software package 
sets new standards with its flexible, powerful and easy to learn user interface. It makes it easy 
for the user to create or import text, barcode or graphic elements and to use these to create a 
complete marking job. Objects and laser-specific parameters can be edited by just a few sim-
ple entries. 
The weldMARK® software package supports the RAYLASE SP-ICE, RLC-USB and RLC-PCI 
control cards. 

1.1 The weldMARK® software package 
The weldMARK® software package is made up of the following modules: 
 weldMARK® graphical user interface  
 COMServer (ActiveX) interface 
 TCP/IP Test Client 
 weldMARK® COM Tester 

 
The sections below provide a brief description of these modules. 

1.1.1 Function overview 
The following weldMARK® functions are particularly important: 
 Opening up to ten jobs simultaneously, easy selection of opened jobs with a click of the 

mouse 
 Support for various laser types, precise control of laser parameters 
 Creation of linear, rectangular, polygonal, drill and bezier objects 
 Output of drill objects as single points or grid points 
 Scaling, moving and rotation of objects on screen 
 Use of objects as templates in the background for easy positioning of marking objects 
 Import of extensive types of vector and bitmap files 
 Support for all TrueType™ fonts installed on the computer (filled or as contour) 
 Serialization functions for text and barcode objects 
 Easy creation of automation scripts 
 Programming of alarms, warnings, user entries for job numbers and batch numbers 
 Control of rotary tables, XY tables or one-dimensional movements using the integrated 4-

axis motor control 
 Detection of object movements with an optional encoder 
 Password protection to restrict users to performing pre-prepared jobs. 
 weldMARK® includes all the elements and tools required for integration into an automated 

process environment. Most procedures can be operated efficiently from within the program 
itself. 

 Support of standard scan heads and various 3-axis subsystems (AXIALSCAN, 
AXIALSCAN motorized, FOCUSSHIFTER) 
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1.1.2 COM automation server API  
weldMARK® provides a COM automation server interface. This enables external programs to 
use the library functions in weldMARK®. For more detailed information, refer to the ComServer 
manual, which is available from RAYLASE. 

1.1.3 TCP/IP test client  
The TCP/IP test client allows the weldMARK® software's server interface to be tested using a 
remote computer. Any errors detected can be corrected over the network using the TCP/IP 
test client. 
The Appendix includes instructions for starting and using the TCP/IP test client. 

1.1.4 weldMARK® COM example program  
The weldMARK® software is supplied complete with a COM example program with source 
text. Use this simple COM automation server program as a template for programming your 
own application programs. 

1.2 Laser safety 
The user is responsible for safe operation and for safeguarding the surrounding area against 
hazards that can be caused by laser radiation. OEM customers must ensure compliance with 
all local and national regulations. 

WARNING: 
Turn on the PC before turning on the laser system. This prevents the laser from behaving in 
an uncontrolled manner when the PC is turned on. 
Check your application carefully before using the laser system. Defective software can block 
the entire system and lead to uncontrolled operation of the laser or deflection unit. 
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1.3 Manufacturer 
RAYLASE AG 
Argelsrieder Feld 2+4 
D-82234 Wessling 
Germany 
Tel.: +49 (0) 81 53 - 88 98 - 0 
Fax: +49 (0) 81 53 - 88 98 - 10 
http://www.raylase.de 
E-mail: info@raylase.de 

1.4 Customer service 
RAYLASE Customer Service can assist you with any queries or problems with weldMARK® or 
this manual. Before contacting Customer Service, note the following information, which will 
enable RAYLASE Customer Service to assist you as effectively as possible: 
 Consult this manual to determine whether you have performed the failed action correctly. 
 Attempt to reproduce the problem and note the exact settings and operator actions that 

lead to the problem.  
 Check and record whether the problem can be prevented by changing the operator actions 

or settings. 
 If possible, create screenshots of all error and event messages. 
 If the problem is with the hardware, refer to the associated manual for details of how to 

resolve or isolate the error.  
 
If you need further assistance, you can contact RAYLASE Customer Service from Monday to 
Friday between 08:00 and 16:00. 
 
Germany (Wessling) 
+49 (0) 81 53 - 88 98 - 0 
 
... Simply contact Customer Service 
 



weldMARK® requirements and installation Chapter 2 

MN013 / v2.0 RAYLASE weldMARK® 9 

2 WELDMARK® REQUIREMENTS AND INSTALLATION 
This chapter provides you with an overview of the system requirements and the necessary 
steps to be taken to install weldMARK®.  

2.1 Hardware requirements 
The following minimum hardware configuration is required: 
 Intel Pentium or compatible computer with operating system  

Windows 2000 (service pack 1), Windows XP Professional or  Windows Vista. 
 CD-ROM drive for installing the software. 
 1024 MB RAM or more is recommended. 
 100 MB free space on the local drive. 

2.2 Installing the dongle  
The weldMARK® software only runs with the dongle supplied. The dongle should be plugged 
into a free USB port on the computer. Every computer on which weldMARK® is installed re-
quires a separate dongle. 

2.3 Software installation 
The procedure for installing weldMARK® is as follows: 
o Start your computer and log in as an administrator. 
o Insert the weldMARK® installation CD in the CD-ROM drive. 

The installation routine starts automatically. 
o Click on the Software installation button and then on Installation weldMARK. 
o Follow the instructions on the screen. 
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3 INTRODUCTION TO THE WELDMARK® SOFTWARE 
PACKAGE 

3.1 Starting and exiting weldMARK®  

Starting weldMARK® 
Select Start >All Programs >RAYLASE >weldMARK. The program starts with the set access 
level (  on page 24, Changing the access level). 
When you start weldMARK®, a new job is created automatically. You can disable this and 
specify that weldMARK® should start with a particular existing job (  on page 150, Settings 
for the job file). 

Exiting weldMARK® 
o Select File >Exit from the menu. 

3.2 Basic concepts 
Marking objects Marking objects represent the graphical elements and texts to be marked by the laser. 

The following object types are available in weldMARK®: 
 Graphic objects, i.e. imported vector or bitmap graphics 
 Line 
 Rectangle 
 Polygon 
 Text 
 Bezier 
 Barcode 
 Drill 
 on page 25, Working with objects 

Template A template is an object that is not marked. It can be used to align objects. 
 on page 93, Templates 

Automation ob-
jects 

Automation objects allow communication with the user and control of external compo-
nents. 

 on page 94, Using automation objects 

Profile Every marking object is assigned a profile, which specifies the parameters for the la-
ser marking. 

 on page 108, Using profiles 

Job A job is a collection of objects and settings. The settings determine the actions of the 
deflection unit, the laser and the additional equipment. 

 on page 119, Job settings, Run job 
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3.3 Access levels 
weldMARK® has three access levels that allow different types of access to the software's 
functions. The program starts with the preset access level (  on page 24, Changing the ac-
cess level). Password protection can be applied to changing the access level (  on page 156, 
System security settings). 

Access levels Description  

All editing functions All software functions can be used with no restrictions.  
 below, "All editing functions" access level 

 

Operator interface only Only saved jobs can be opened and executed. The jobs cannot be 
modified. 

 on page 22, "Operator interface only" access level 

Touchscreen interface  Only saved jobs can be opened and executed. The jobs cannot be 
modified. 
The design of this access level is optimized for touch screens. Mouse 
control is also possible. 

 on page 23, "Touchscreen interface" access level 
 

3.3.1 "All editing functions" access level 
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(1) Title bar 
The title bar shows the name of the current job, the company name and the name of the pro-
gram. 

(2) Job Manager 
The Job Manager shows the name of the current job with the ele-
ments of the job settings below. The installed control cards are 
also listed. 
To view or edit a job setting, double click on the corresponding 
element. Right clicking on the element displays a pop-up menu 
containing element-specific options. 
(  on page 119, Editing the job settings) 

S006 
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(3) Menu bar 
The menu bar contains the following menus (some menu commands are only available after 
setting the corresponding function or setting up the corresponding hardware drivers): 

File menu  

New Opens a new job with a blank 
workspace. 

Open Job...  Allows you to open a saved job. 

Up to ten jobs can be opened  
simultaneously. 

Close Job Closes the current job. 

Close All Jobs Closes all open jobs. 

Import...  Allows you to select and import objects in different file formats. 

Export...  Allows you to export the currently selected weldMark® objects in various 
file formats. 

Import and Export Pro-
files... 

Opens the Import/Export Wizard for profiles. Profiles can be exported 
from or imported to the Profile Manager. 

Save Job  Saves the current job. The first time you save a new job, the Save Job as 
window will be opened. You must specify a file name and a storage loca-
tion. 

Save Job As...  Allows you to save a new job or to save an open job under a new name. 

Save Job to Embedded 
Controller 

Jobs can be saved to a stand alone control card and executed from here 
without the need for a PC (  on page 131, Enabling "Save to stand 
alone control card" mode). 

Print Setup... Allows you to enter settings for the printer you want to use. 

Print  Allows you to enter print settings, change printer settings and start print-
ing of the current job. 

Exit  Exits the weldMARK® program. 
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Menu Edit  

Undo  Reverses the last action performed. You can undo the last ten actions. 

Cut Removes all selected objects from the job and sends them to the clip-
board. 

Copy Copies all selected objects to the clipboard. 

Paste Pastes objects copied or cut in weldMARK® into the current job. 

Paste Special Allows objects on the clipboard to be pasted into the current job as im-
age or text objects.  
This command enables you to paste objects from other applications. 

Delete  Deletes all selected objects. 

Select All  Selects all objects contained in the current job. 

Snap To Guidelines If this function is enabled, objects are aligned with the guidelines when 
you move them. 

Snap To Grid  If this function is enabled, objects are aligned with the grid lines when 
you move them. 

 

View menu  

Host Monitor This command shows or hides the host interface monitor. The host  
monitor allows you to observe the communication between a host and 
weldMARK® (  on page 151, Editing the host interface settings). 

Job Manager This command shows and hides the Job Manager. 

Object Manager  This command shows and hides the Object Manager. 

Profile Manager This command shows and hides the Profile Manager. 

Motor Manager Only available if a motor control card is installed. 
Opens the window for operating the optional stepper motor control card. 

Guidelines  Shows or hides guidelines. 

Grid  Shows or hides grid lines. 

Rulers Shows or hides rulers. 

Millimeters  

Inches  

Bits  

Selects the unit for the ruler display and for the input dialog boxes. 
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Objects menu  

The following submenus are available: 

Automation... Opens a window for selecting an automation object. 

Barcode... 

Drill... 

Line 

Polygon 

Rectangle 

Text 

Add 

Bezier 

Inserts the selected object in the center of the work-
space. 

Convert To Template Converts the selected object into a template. The template is automati-
cally added to the Job Manager. 

Lock Object 
Unlock Object 

Locks or releases the selected object for editing. 

Lock All/ 
Unlock All 

Locks or releases all objects in the job for editing. 

Defaults...  Allows you to make default settings for the various object types. 

Dimensions... Allows you to change the size, shape and position of the selected ob-
jects. 

Properties... Allows you to edit various parameters of the selected objects. 
 

Profiles menu  

Add to Profiles... The parameters of the selected object can be combined under a profile 
name and added to the Profile Manager under that name. 

Organize Profiles... Allows you to specify the folder structure for the profiles. 
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. 

Job menu  

Preview Creates a frame representing the rectangular boundaries of the selected 
objects using the visible pointer and opens the "Preview" window. This 
window allows you to adjust the boundaries of the objects to the target 
object. 
(To activate the visible pointer  on page 166, Configuring a laser 
driver). 

QuickMark  Allows you to start execution of either the selected objects or all objects 
included in the job. Automation objects are skipped. 

Run... Allows you to start execution of the current job including all marking and 
automation objects. 

Run from Hardware… To ensure that they are executed without interruption, jobs are first sent 
to the control card and then started. This function is particularly useful 
when using a slow PC. 
(  on page 129, Run from Hardware) 

Convert Template 
to Object 

Converts the selected template into a marking object. 

Settings... Allows you to make job-specific settings. 
 

Tools menu  

Configure Tools Allows you to add external programs to the Tools menu. 

Align...  Allows you to align selected objects with one another based on particular 
settings. 

Grid/Guidelines... Allows you to set parameters for the grid and for guidelines. 

Configure I/O Cards... Starts the Configuration Wizard for the I/O card. 

I/O Card&Diagnostics... Allows you to check the ports of the standard I/O board. 

Laser Diagnostics tool Allows you to set parameters for the laser radiation and to test the posi-
tion and effect of the laser beam. 

 



Introduction to the weldMARK® software package Chapter 3 

MN013 / v2.0 RAYLASE weldMARK® 17 

 

System menu  

Preferences... You can make various settings for working with weldMARK®. 

Properties... Displays the properties of the operating system and the hardware rele-
vant for weldMARK®. 

Globals... Allows you to enter general settings for the laser power, the marking 
speed and the marking offset. weldMARK® can thus be adjusted for 
changed external parameters, e.g. a diminishing laser power. 

Run from Host... Sets weldMARK® to host mode, enabling it to accept commands from 
external host programs. 

Access level Allows you to change the access level. Any 
changes take effect immediately. 

Change Pass-
word  

You can set up password protection for changing 
the access level, change the password or cancel 
password protection. 

Security 

Startup Options Sets the access level used when you start the pro-
gram. 

Backup... Opens the Browse for Folder window. In the structure tree in this win-
dow, you can select a storage location for the backup file containing the 
weldMARK® system settings. 

Restore...  Opens the Restore Application Settings window. In this window, you can 
select a backup file. Opening the file restores the saved system settings 
for weldMARK®. 

 

Help menu  

Content & Index Allows you to use weldMARK online help. 

Online Updates... Displays information about the current program version. 
Clicking on Check for Updates calls up the RAYLASE homepage, pro-
vided you are connected to the Internet. 

About...  Displays the currently installed weldMARK® version number. The Info 
button can be used to obtain additional copyright information. 
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(4) Tool bars  
The toolbars provide fast access to frequently used functions.  
 
The toolbar below the menu bar contains the following standard commands: 

 
Install New File...  Nd:YAG only 

Reduce laser power to minimum 

 
Open Job  QuickMark 

 
Save Job  Starting execution 

 
Save as  Show/Hide Job Manager 

 
Print job  Show/Hide Profile Manager 

 
Cut selection  Text attribute bold 

 
Copy selection  Text attribute italics 

 
Paste selection (special)  Align text left 

 
Delete selection  Center text 

 
Undo  Align text right 

 
Import job  Change Access Level 

 
Export Graphic  Change Password 
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The toolbar on the left-hand edge of the screen contains functions for adding, selecting 
and manipulating objects: 

 
Select objects  Show/Hide guide-

lines 

 
Zoom in  Snap To Guide-

lines 

Only available if 
guidelines have 
been entered. 

 
Zoom out  Show/Hide grid 

 
Full view  Snap To Grid 

 
Insert line object  Set dimensions 

 
Insert rectangle object    

 
Insert polygon object    

 
Insert Bezier object    

 
Insert text object    

 
Insert barcode object    

 
Insert automation object    

 
Insert drill object    

(5) Rulers 
The rulers can be displayed with the following units: "Millimeters", "Inches" or "Bits". The rul-
ers are scaled automatically based on the correction file for the deflection unit lens. 

(6) Profile Manager 
The Profile Manager displays a hierarchical overview of the profile 
folders and profiles created by the user. Profiles can be applied to 
selected objects or to all objects in a job. To do this, right click on 
the corresponding profile and select the required option in the pop-
up menu. Double clicking on the profile allows you to modify its 
parameters. 
(  on page 108, Using profiles) 

S010
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(7) Object Manager 
The Object Manager lists all marking and automation objects in 
the job. The objects appear in the order in which they were cre-
ated and will subsequently be executed. You can change the or-
der of the objects using the blue arrow buttons in the Object Man-
ager screen. 
The number of objects in a job is specified in the Object Manager 
title bar. You can select an object by clicking on it in the Object 
Manager or by entering the corresponding index number in the 
Index input box. 
The Mark object check box for certain objects allows you to spec-
ify that you want the object contour to be marked. For an object 
that does not have any contour (e.g. a bitmap object), this option 
specifies whether the object is to be marked. 
For objects to which you can apply an object fill, the Mark fill op-
tion can be used to specify that the object fill is to be marked. 
(  on page 25, Working with objects) 
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(8) The  “Jobs” tabs 
The tabs at the bottom of the screen provide an overview 
of the currently open jobs and allow you to select these 
jobs directly. 
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(9) Workspace 
The size of the workspace can be set individually or automatically adjusted to the size of the 
operating field of the deflection unit (  on page 120, Job settings - "Page Setup"). The maxi-
mum size of the workspace is determined by the size of the deflection unit's operating field. 
Objects that are (partly) located outside the workspace are not marked. 
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Pop-up menu 
The pop-up menu provides fast access to frequently used 
functions for editing objects. 
o Right click on an object to open the pop-up menu. 
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The following functions are available: 

QuickMark... Allows you to start execution of either the selected objects or all objects 
included in the job. Automation objects are skipped. 

PreviewMark... Creates a frame representing the rectangular boundaries of the selected 
objects using the visible pointer and opens the "Preview Mark" window.  
This window allows you to adjust the boundaries of the objects to the 
target object. 
(To activate the visible pointer  on page 166, Configuring a laser 
driver). 

Cut Removes all selected objects from the job and sends them to the clip-
board. 

Copy Copies all selected objects to the clipboard. 

Convert To Template Converts the selected object into a template. The template is automati-
cally added to the Job Manager. 

Lock Object  
Unlock Object 

Locks or releases the selected object for editing. 

Delete Deletes all selected objects. 

Add to Profiles... The parameters of the selected object can be combined under a profile 
name and added to the Profile Manager under that name. 

Copy Profile Copies the profile for the selected object to the clipboard. 

Paste Profile  Applies the profile saved to the clipboard to the selected object. 

Dimensions... Allows you to change the size, shape and position of the selected ob-
jects. 

Properties Allows you to edit various parameters of the selected objects. 



Chapter 3 Introduction to the weldMARK® software package 

22 RAYLASE weldMARK® MN013 / v2.0 

3.3.2 "Operator interface only" access level 
This access level only allows the user to open and execute prepared jobs. The jobs to be 
executed must be located in the preset folder (  on page 150, Settings for the job file). 

 
The following functions are available: 

File >Open Job... 
 

Allows you to open a saved job. 

File >Exit  Exits the weldMARK® program. 

Job >Run...  
 

Allows you to start execution of the current job including all 
marking and automation objects. 

 
 

Changing access level If password protection is activated, you 
need to enter the password to change access level. 
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3.3.3 "Touchscreen interface" access level 
This access level only allows the user to open and execute prepared jobs. The jobs to be 
executed must be located in the preset folder (  on page 150, Settings for the job file). 
The design of the user interface is optimized for touch screens. Mouse control is also possi-
ble. 

 
 
The following functions are available: 

Job Manager Allows you to open a saved job. Only one job at a time can be opened. 

Run Job Executes the open job. 

Stop Stops execution of the job. 

Job Status The graphic shows the workspace and the marking objects positioned on 
it. 

System Status The fields show the status of interlocks 1 to 8. Depending on the setting, 
a particular status can be a prerequisite for marking individual or all ob-
jects. The names of the interlock fields can be changed. 

Options Allows you to adjust the job for changed external conditions (  on page 
155, Global) or to change the access level (  on page 24, Changing the 
access level). 

Shutdown Exits the weldMARK® program and shuts down Windows. 
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Access level 

3.3.4 Changing the access level 

From the "All editing functions" or "Operator interface only" access level 
o Select the System >Security >User Access option 

or click on the Change Access icon. 
If password protection is activated, you will be 
prompted to enter the password.  
The adjacent window is opened. 

o Select the required access level. 

S004

 

From "Touchscreen interface" access level 
o Touch the OPTIONS button. 

The adjacent window is opened. 
o Touch the FULL ACCESS button. 

If password protection is activated, you 
will be prompted to enter the password. 
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4 WORKING WITH OBJECTS 
This chapter provides an overview of the objects available in weldMARK® and describes how 
to use them. 

4.1 Basic principles 

4.1.1 Selecting and deselecting objects 
Objects must be selected in order for you to be able to edit them or display their properties. 
You can select multiple objects at the same time. Selected objects are identified by squares 
(resizing handles) around them and by emphasis in the Object Manager. 

Selecting objects with the selection tool 
o Select the Selection tool icon in the toolbar.  
o Click on the desired object with the arrow cursor. 
o To select multiple objects, either hold down the mouse button and draw a rectangle with 

the arrow cursor around all objects you want to select or hold down the Shift key and click 
on the objects you want to select in turn. 

Selecting objects using the Object Manager 
o Click on the desired object in the Object Manager. 
o To select multiple objects, click on the first object in the Object Manager. Hold down the 

Ctrl key and then click on all of the other objects you want to select. 

Selecting all objects 
o Select the Edit >Select All option from the menu. 

Deselecting objects 
o Select the Selection tool  icon in the toolbar. 
o With the arrow cursor, click on a point outside the object or object group,  

or  
click on a free space in the Object Manager. 

 
Selection tool 

 
Arrow cursor 

 
Selection tool 
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>Lock Object 

4.1.2 Moving objects 
o Select the desired objects. 
o Click on the objects and, with the mouse button held down, drag them to the desired 

position 
or 
use the Nudge tool (  on page 87, Nudging objects). 

4.1.3 Locking and unlocking objects 
Locked objects cannot be edited or deleted. This prevents the object or its properties from 
being inadvertently modified. 
 

 

Unlocked 
object 

o Click on the object to be locked. 
o Select the Objects >Lock Object option from the menu.

The resizing handles for locked objects appear as 
unshaded squares. 

o You can use the Objects >Unlock Object command to 
release the object for editing. 
The resizing handles for unlocked objects appear as 
shaded squares. 

 
 

 

Locked object 

4.1.4 Object types 
The following object types are available in weldMARK®: 

Graphic objects  

 
Line 

 
Rectangle 

 
Polygon 

 
Polyline 

 
Bezier 

 
Text 

 
Barcode 

Marking  
objects 

 
Drill  

The adjacent marking object types can be selected. 

Automation 
objects  

Automa-
tion... 

Automation objects allow communication with the user and 
control of external components. 
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4.1.5 Object defaults 
Object defaults are set for some objects. For example, when creating new polygons the num-
ber of corners is preset. You can change these object defaults: 
o Select the Objects >Defaults... option from the 

menu. 
The adjacent window is opened.  

 
The table below lists all object types for which 
object defaults exist. 

S089

: 

Polygon  on page 47, Defaults for Polygon Objects 

Text...  on page 53, Defaults for Text Objects 

1D Barcode 

2D Barcode 

 on page 61, Defaults for barcode objects 

Bitmap Graphic  on page 38, Defaults for bitmap objects 

Wait for External Signal  on page 95, Defaults for "Wait for External Signal" 

Set I/O Port  on page 97, Defaults for "Set I/O Port" 

Show Messagebox  on page 100, Defaults for "Show Messagebox" 

4.1.6 Object properties 
You can change the properties of objects as follows: 
o Right click on an object. 
o Select the Properties... option from the menu. 
o Make the required changes. Refer to the following sections to see which properties are 

possible for which objects. 
 
The following properties can be set for all object types: 
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Notes 
Notes can be added to objects as follows: 
o Right click on the object to which you want 

to add a note. 
o Select the Properties... option from the 

menu.  
o Notes tab. 

The adjacent window is opened. 
o Enter the desired text. 
o Confirm your entry with the OK button. 
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External Control 
During execution of the job, each individual marking object can be marked or skipped depend-
ing on external signals. The settings for this can be called up as follows: 
o Right click on the object to which you want 

to add external marking control. 
o Select the Properties... option from the 

menu. 
o Select the Ext. Control tab. 

The adjacent window is opened.  
Refer to the table below for explanations. 

S014

 

External control activated If this function is enabled, the I/O ports are checked before marking the 
selected object. If they match the setting in IN1-IN6 the object is marked, 
otherwise it is skipped. 

I/O Port Select the input ports to be checked. 

IN1–IN6 Specification for port status (high / low). 
If the specification is met, the object is marked. If the specification is not 
met, the object is skipped. 

 
(  on page 173, Standard I/O card / Interlock card) 
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4.2 Importing a job 
A job is a collection of objects and settings. The settings determine the actions of the deflec-
tion unit, the laser and the additional equipment. If a job is imported into another job, the ob-
jects and settings it contains will be added to the currently open job.  
o Select the File >Import... 

option from the menu. 
The adjacent window is 
opened.   
Refer to the table below 
for explanations. 
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Look in Allows you to choose the folder in which the job to be imported is saved. 

File name This text box displays the name of the currently selected file. 

The file type for a job file must be selected. Only files of the selected type will be dis-
played. 
The following file formats can be imported: 

weldMARK Job (*.wmj) A weldMARK® job file format. 

TruviewJob (*.job) A file format developed by GSI Group Inc. based on the 
Truview® software package. 

winLase Job (*.wlj) A WinLase job file format. 

File type 

remaining  on page 31, Importing vector graphic files. 
 on page 37, Importing bitmap files. 
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4.3 Importing and editing vector graphic objects 

4.3.1 Importing vector graphic files 
Mathematically, vector graphics are defined as a sequence of points connected by lines. They 
can be scaled as required with no loss of quality. They are ideally suited for use with laser 
processing systems as the deflection unit is a vector output device. 
o Select the File >Import... 

option from the menu. 
The adjacent window is 
opened. 

 
The table below contains 
explanations of the vector 
graphic formats that can be 
imported. 
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CAD Drawings File formats and export formats of different CAD programs 
(*.dgw; *.dxf; *.plt; *.hgl; *.hg; *.hpg; *.plo; *.hp; *.hp1; 
*. hp2; *.hpgl ; *. hpgl2; *.gl2; *.pm; *.spl; *.rtl; *.cgm; 
*.svg) 

weldMARK Object weldMARK® format for objects (*.wlo). 

HPGL Plotter File The industry standard (*.plt); this format is primarily used for 
output to a pen plotter.  
Note that the resolution of the plotter file to be imported must 
match the resolution set in weldMARK so that the output size 
will be displayed correctly in weldMARK. The resolution in 
weldMARK depends on the F-Theta lens used. It is referred to 
as the calibration factor and can be seen under System >Pref-
erences on the Hardware tab. 

Windows Enhanced 
Meta File 

A format developed by Microsoft (*.emf). It can be used to store 
both vector graphic information and bitmaps embedded in the 
file. 
When vector graphic objects are copied to the clipboard, EMF 
format is used.  

Windows Meta File A format developed by Microsoft (*.wmf), the precursor to the 
EMF format. 

AutoCAD An export format (*.dxf), normally from AutoCAD®. 

Encapsulated Post-
Script  

A format that is normally used as an output format for printing 
(*.eps). 

File type 

remaining  on page 30, Importing a job. 
 on page 37, Importing bitmap files. 

 
Import... 
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4.3.2 Properties of a vector graphic object 
Vector graphics are assigned properties that determine how they are displayed on the screen 
and the behavior during laser processing. These properties are divided up as follows:  

Profile The object is assigned a marking profile. The pa-
rameters of this profile can be changed. 

 on page 108, Using pro-
files 

Settings Various settings can be made for the object.  on page 33, Settings for a 
vector graphic object 

Source Allows you to view the path to the source file.  on page 34, Source file for 
a vector graphic object 

Fill  Fill parameters can be entered for the object.  on page 69, Object fill 

Notes A note can be assigned to the object.  on page 28, Notes 

Ext. Control A marking condition can be applied to the object. If 
the external control is activated, external signals 
determine whether the object is marked or skipped. 

 on page 29, External Con-
trol 
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Settings for a vector graphic object 
Every vector graphic object is assigned specific settings that can be called up and, if neces-
sary, modified as follows: 
o Right click on a vector graphic object. 
o Select the Properties... option from the 

menu.  
o Select the Settings tab. 

The adjacent window is opened.  
Refer to the table below for explanations. 

S007

 

Name The object name entered in this text box is used to list the object in the 
Object Manager. The name also appears in all information and dialog 
boxes relating to that object. 

On screen color The color selection list can be used to select one of the preset colors to 
display the object on screen. 

Mark object If this function is enabled, the object contour is marked. The function is 
enabled by default. 

Mark fill If this function is enabled, the object fill is marked. The function can only 
be enabled if a fill has been set. This function is disabled by default. 

Display vector jumps If this function is enabled, the vector jumps between the individual part of 
the object are displayed on screen. The function is disabled by default. 

Mark to If more than one control card is installed, this drop-down menu can be 
used to set the control card to be used for marking the object. 
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Source file for a vector graphic object 
Vector graphic objects are created in external programs and imported into weldMARK®. The 
path to the source file can be viewed as follows: 
o Right click on a vector graphic object. 
o Select the Properties... option from the 

menu. 
o Select the Source tab. 

The adjacent window is opened.  
Refer to the table below for explanations. 
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Image rules No rules can be configured for graphic objects. 

Current This field specifies the path to the source file. 
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CAD settings of a vector graphic object 
For vector graphic objects of the type CAD an additional tab „CAD“ is available. This tab is 
called as follows: 
o Right click on a vector graphic object. 
o Select the Properties... option from the 

menu. 
o Select the CAD tab. 
o The adjacent window is opened.  

Refer to the table below for explanations. 
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Layers All layers of the vector graphic object are listed. 

Pen Colors A specific pen can be defined for every layer. Eight predefined pens are 
available (Pen 1 to Pen 8). Via the profile settings its possible to set 
marking parameters for each pen seperately (  on page 108, Marking 
object profile). 

Mark Layer Via this field marking can be activated or deactivated for each layer  
seperately. 

Extract to New Object With clicking this button, the selected layer is removed from the vector 
graphic object and added as a new object to the object manager. 
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4.3.3 Exporting vector graphics 
Vector graphic objects can be exported for use in other programs. 
o Right click on the vector graphic you want to 

export. 
o Select the File >Export... option from the 

menu. 
The adjacent window is opened.  
Refer to the table below for explanations. 
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Save in Folder in which you want to save the graphic. 

File name The object name is suggested as the file name. However, you can overwrite 
this with the name of your choice. 

The graphic can be saved in the following formats: 

PLT HPGL Plotter File 

Save as  type 

WLO weldMARK® object format 
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4.4 Importing and editing bitmap objects 

4.4.1 Importing bitmap files 
A bitmap is a rectangular grouping of pixels. For laser marking, the bitmap must be rasterized. 
As the deflection unit is a vector output device, this raster has to be simulated. To do this, the 
laser beam moves repeatedly over the image and marks a series of pixels each time. This 
process can take a long time. It normally takes longer to mark a bitmap representation of an 
object than a vector representation. However, some images only allow bitmap marking, e. g. 
photographs. 
weldMARK® supports the import of bitmap files with monochrome, gray or colored content. 
Once imported, all images are automatically converted into gray scale images. 
o Select the File >Import... 

option from the menu. 
The adjacent window is 
opened. 

 
The table below contains 
explanations of the bitmap 
formats that can be imported. 
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Windows Bitmap 
(BMP)  

A Windows bitmap format.  

JPEG Bitmap 
(JPG) 

CompuServe 
Bitmap (GIF) 

Compressed bitmap format. 

PaintBrush (PCX) A PaintBrush bitmap format. 

Files of type 

remaining  on page 31, Importing vector graphic files. 
 on page 30, Importing a job. 
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4.4.2 Defaults for bitmap objects 
This section describes how you can call up and modify the defaults for bitmap objects. The 
defaults affect all new bitmap objects. 
o Select the Objects >Defaults... option from the 

menu. 
The adjacent window is opened.  
Refer to the table below for explanations. 
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Contrast  The relationship between dark and light pixels in the image can be 
changed.  

Brightness  The brightness of all pixels in the bitmap image can be changed.  

Invert pixels  Enabling this function creates a negative of the original bitmap. 

4.4.3 Properties of a bitmap object 
Bitmap objects are assigned properties that determine how they are displayed on the screen 
and the behavior during laser processing. These properties are divided up as follows: 

Profile The object is assigned a marking profile. The pa-
rameters of this profile can be changed. 

 on page 108, Using pro-
files 

Settings Various settings can be made for the object.  on page 39, Settings for a 
Bitmap Object 

Source Allows you to view the path to the source file.  on page 41, Source file for 
a bitmap object 

Notes A note can be assigned to the object.  on page 28, Notes 

Ext. Control A marking condition can be applied to the object. If 
the external control is activated, external signals 
determine whether the object is marked or skipped. 

 on page 29, External Con-
trol 
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Settings for a Bitmap Object 
Every bitmap object is assigned specific settings that can be called up and, if necessary, 
modified as follows: 
o Right click on a bitmap object. 
o Select the Properties... option from the 

menu. 
o Select the Settings tab. 

The adjacent window is opened.  
Refer to the table below for explanations. 
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Name  The object name entered in this text box is used to list the object in the Object 
Manager. The name also appears in all information and dialog boxes relating to 
that object. 

Pixel density The pixel density can be changed. 

Contrast  The difference between lightest and darkest pixels can be modified. 

Brightness  The brightness of the marking result can be changed. If the value is increased, 
the laser rests on each pixel for longer; the marking result will be brighter or 
darker depending on the material. 

Mark object Enabling this function means that the object will be marked. The function is en-
abled by default. 

Display vector 
jumps 

If this function is enabled, the vector jumps between the individual part of the ob-
ject are displayed on screen. The function is disabled by default. 

Depending on the kind of the bitmap object and the set laser type, the following 
modes can be selected ( on page 40, Selectable bitmap modes). 

PWM If this function is selected, the laser power is controlled via 
pulse width modulation. 

Analog If this function is selected, the laser power is controlled via 
an analog signal  (0V to10V). 

Digital If this function is selected, the laser power is controlled via a 
digital signal (8bit digital output). 

Timed If this function is selected, the stored energy in the cavity of 
the laser will be used. 

Bitmap mode 

Error Diffusion If this function is selected, the bitmap object is converted 
into a monochrome bitmap using the default error diffusion 
algorithm. Black pixels are positioned in a way that the pic-
ture seems to consist of shades of grey. 
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Invert pixels Creates a negative of the original bitmap object. 

Single direction Bitmap objects are marked a line at a time, with marking being performed in an 
alternating direction. If this function is enabled, marking is only performed in one 
direction, which can improve the marking quality (deactivates the hysteresis of the 
scanner mirror). 

Ign. black pixels During marking, the laser beam ignore pixels that have a 100% black value and 
are not therefore to be marked. This reduces the processing time. 

Invert corners If bitmap objects have been rotated, each corner can contain pixels that are not in 
the original. The color of these superfluous pixels can be set to black (no marking) 
or white. 

Shift correction Mechanical inertia and laser specific delay may cause hysteresis errors in the 
bidirectional operation, especially when marking with high speed. 
Via the parameter Shift Correction this hysteresis can be compensated. 

 
not corrected 

 
compensated 

 
correction value too high  

Bitmapline delay Via this parameter an idle time is defined. The next line is marked not until the set 
time is elapsed. 

Min. pixel. Via this parameter a minimum grey value is defined. Only pixels of a bitmap ob-
ject of the same or higher value are marked. If more than three pixels are to be 
ignored, automatically a jump command is performed to the next pixel to be 
marked. This may increase the marking speed. 
The value for Min. pixel. ranges from OFF to 1000. 
If the value is set to OFF, 0 or 1, no pixels are skipped. 

Format: The recognized file format of the bitmap object is displayed. 

Mark to If more than one control card is installed, this drop-down menu can be used to set 
the control card to be used for marking the object. 

 
Selectable bitmap modes  

Bitmap mode Type of 
laser 

Setting for 
laser power 

PWM 
(Point&Shoot) 

Analog Digital Timed 
„FPS“-Mode 

Error Diffusion 

CO2 PWM ●    ● 3 

Analog 1 ● ●  ● ● 3 YAG 

Digital 2 ●  ● ● ● 3 

IPG Digital 2 ●  ●  ● 3 

SPI Analog 1 ● ● 4 ● 5  ● 3 

SLOW – ●     

PCD – ●     
● = selectable, 1 = DAC,  2 = Port B, 3 = not possible for combination with monochrome bitmaps 
4 = Basic Interface,  5 = Extended Interface 
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Source file for a bitmap object 
Bitmap objects are created in external programs and imported into weldMARK®. The path to 
the source file can be displayed as follows: 
o Right click on a bitmap object. 
o Select the Properties... option from the 

menu. 
o Source tab. 

The adjacent window is opened.  
Refer to the table below for explanations. 
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Image rules No rules can be configured for graphic objects. 

Current This field specifies the path to the source file. 
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4.5 Adding and editing marking objects 
Marking objects are all objects that can be marked with a laser. weldMARK® allows you to 
select the following marking object types: 

 
Line 

 
Rectangle 

 
Polygon 

 
Bezier 

 
Text 

 
Barcode 

 
Drill  

 
The sections below describe how marking objects are added to a job and how these objects 
can subsequently be modified. 
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4.5.1 Line objects 
A line is a one-dimensional object. It causes the laser to mark a straight line. 

Adding a Line Object 
o Select the Objects >Add >Line option from the menu. 

A new line is inserted in the center of the workspace. 
 

Properties of a Line Object 
Line objects are assigned properties that determine how they are displayed on the screen and 
the behavior during laser processing. These properties are divided up as follows: 

Profile The object is assigned a marking profile. The pa-
rameters of this profile can be changed. 

 on page 108, Using pro-
files 

Settings Various settings can be made for the object.  on page 44, Settings for a 
Line ObjectSettings for a 
Line Object 

Notes A note can be assigned to the object.  on page 28, Notes 

Ext. Control A marking condition can be applied to the object. If 
the external control is activated, external signals 
determine whether the object is marked or skipped. 

 on page 29, External Con-
trol 

 

 
New line 



Chapter 4 Working with objects 

44 RAYLASE weldMARK® MN013 / v2.0 

Settings for a Line Object 
Every line object is assigned specific settings that can be called up and, if necessary, modified 
as follows: 
o Right click on a line object. 
o Select the Properties... option from the 

menu. 
o Select the Settings tab. 

The adjacent window is opened.  
Refer to the table below for explanations. 
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Name  The object name entered in this text box is used to list the object in the 
Object Manager. The name also appears in all information and dialog 
boxes relating to that object. 

On screen color The color selection list can be used to select one of the preset colors to 
display the object on screen. 

Mark object  Enabling this function means that the object will be marked. The function 
is enabled by default. 

Display vector jumps If this function is enabled, the vector jumps between the individual part of 
the object are displayed on screen. The function is disabled by default. 

Mark to If more than one control card is installed, this drop-down menu can be 
used to set the control card to be used for marking the object. 
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4.5.2 Rectangle objects 
A rectangle is a marking object with four corners. 

Adding a Rectangle Object 
o Select the Objects >Add >Rectangle option from the menu. 

A new rectangle object is inserted in the center of the workspace. 
 

Properties of a Rectangle Object 
Rectangle objects are assigned properties that determine how they are displayed on the 
screen and the behavior during laser processing. These properties are divided up as follows: 

Profile  The object is assigned a marking profile. The pa-
rameters of this profile can be changed. 

 on page 108, Using pro-
files 

Settings Various settings can be made for the object.  on page 46, Settings for a 
Rectangle Object 

Fill  A fill can be applied to the object.  on page 69, Object fill 

Notes A note can be assigned to the object.  on page 28, Notes 

Ext. Control A marking condition can be applied to the object. If 
the external control is activated, external signals 
determine whether the object is marked or skipped. 

 on page 29, External Con-
trol 

 
New rectangle 
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Settings for a Rectangle Object 
Every rectangle object is assigned specific settings that can be called up and, if necessary, 
modified as follows: 
o Right click on a rectangle object. 
o Select the Properties... option from the 

menu.  
o Select the Settings tab. 

The adjacent window is opened.  
Refer to the table below for explanations. 
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Name  The object name entered in this text box is used to list the object in the 
Object Manager. The name also appears in all information and dialog 
boxes relating to that object. 

On screen color  The color selection list can be used to select one of the preset colors to 
display the object on screen. 

Mark object If this function is enabled, the object contour is marked. The function is 
enabled by default. 

Mark fill  If this function is enabled, the object fill is marked. The function can only 
be selected if a fill has been set. This function is disabled by default. 

Display vector jumps If this function is enabled, the vector jumps between the individual part of 
the object are displayed on screen. The function is disabled by default. 

Mark to If more than one control card is installed, this drop-down menu can be 
used to set the control card to be used for marking the object. 
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4.5.3 Polygon objects  
A polygon object is an object that can be marked and has a definable number of sides of 
equal length. The distance from a corner to the center of the object is always the same. 

Defaults for Polygon Objects 
This section describes how you can call up and modify the defaults for polygon objects. The 
defaults affect all new polygon objects. 
o Select the Objects >Defaults... option from the 

menu. 
o Select the object type Polygon. 

The adjacent window is opened.  
Refer to the table below for explanations. 

S089

 

Sides  All new polygons are created with the number of corners entered. 

 

Adding a Polygon Object 
o Select the Objects >Add >Polygon option from the menu. 

A new polygon is inserted in the center of the workspace. 
 

Properties of a Polygon Object 
Polygon objects are assigned properties that determine how they are displayed on the screen 
and the behavior during laser processing. These properties are divided up as follows: 

Profile The object is assigned a marking profile. The pa-
rameters of this profile can be changed. 

 on page 108, Using pro-
files 

Settings Various settings can be made for the object.  on page 48, Settings for a 
polygon object 

Fill  A fill can be applied to the object.  on page 69, Object fill 

Notes A note can be assigned to the object.  on page 28, Notes 

Ext. Control A marking condition can be applied to the object. If 
the external control is activated, external signals 
determine whether the object is marked or skipped. 

 on page 29, External Con-
trol 

 
New polygon 
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Settings for a polygon object 
Every polygon object is assigned specific settings that can be called up and, if necessary, 
modified as follows: 
o Right click on a polygon object. 
o Select the Properties... option from the 

menu.  
o Select the Settings tab. 

The adjacent window is opened.  
Refer to the table below for explanations. 
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Name  The object name entered in this text box is used to list the object in the 
Object Manager. The name also appears in all information and dialog 
boxes relating to that object. 

On screen color  The color selection list can be used to select one of the preset colors to 
display the object on screen. 

Mark object If this function is enabled, the object contour is marked. The function is 
enabled by default. 

Mark fill  If this function is enabled, the object fill is marked. The function can only 
be selected if a fill has been set. This function is disabled by default. 

Display vector jumps If this function is enabled, the vector jumps between the individual part of 
the object are displayed on screen. The function is disabled by default. 

Sides Specifies the number of sides for the polygon. 

Start angle Specifies the angle position at which the first line segment begins. An 
angle of "0" corresponds to the 12:00 position on a clock. 

End angle Specifies the angle position at which the first line segment ends. 

Mark to If more than one control card is installed, this drop-down menu can be 
used to set the control card to be used for marking the object. 
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Bezier 

4.5.4 Bezier objects 
Bezier objects are markable. This object kind consists of free-style spline curves. The object 
shape is defined by points and it can be changed by moving these points. 

Adding a bézier object 
o Select menu item Objects >Add >Bezier. 

A new bezier object is added to the center of the screen. 
 

Properties of a bezier object 
Bezier objects are assigned properties that determine how they are displayed on the screen 
and the behavior during laser processing. These properties are divided up as follows: 

Profile The object is assigned a marking profile. The pa-
rameters of this profile can be changed. 

 on page 108, Using pro-
files 

Settings Various settings can be made for the object.  on page 50, Settings of a 
bézier object. 

Fill  A fill can be applied to bezier objects with a closed 
contour. 

 on page 69, Object fill 

Notes A note can be assigned to the object.  on page 28, Notes 

Ext. Control A marking condition can be applied to the object. If 
the external control is activated, external signals 
determine whether the object is marked or skipped. 

 on page 29, External Con-
trol 
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Settings of a bézier object 
Every bezier object is assigned specific settings that can be called up and, if necessary, modi-
fied as follows: 
o Right click on a bezier object. 
o Select the Properties... option from the 

menu.  
o Select the Settings tab. 

The adjacent window is opened.  
Refer to the table below for explanations. 

S226
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Name  The object name entered in this text box is used to list the object in the 
Object Manager. The name also appears in all information and dialog 
boxes relating to that object. 

On screen color  The color selection list can be used to select one of the preset colors to 
display the object on screen. 

Mark object If this function is enabled, the contour lines (shape) of the characters will 
be marked. The function is enabled by default. 

Mark fill If this function is enabled, the character fill is marked. The function can 
only be enabled for TrueType fonts and if a fill has been set for the ob-
ject. 
This function is disabled by default. 

Display vector jumps If this function is enabled, the entire sequence of movements is dis-
played on the screen, including the times in which the laser is deacti-
vated while moving to the next vector to be marked (vector jumps). The 
function is disabled by default. 

Mark to If more than one control card is installed, this drop-down menu can be 
used to set the control card to be used for marking the object. 
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Modifying the shape of a bezier object 
A bezier object is inserted with a standard shape. The shape can be modified as desired as 
described in the following: 
o Left click on a bezier 

object. 
o Press key F6.  

The adjacent window is 
opened.  
Refer to the table below 
for explanations. 

S226 
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Add Point  A new point is inserted behind the current point (no. 6 in the picture 
above). 

Insert Point  A new point is inserted behind the selected point. 

Delete Point The selected point is deleted. 

Close Contour As described for the function Add Point, a new point is inserted behind 
the last point. Using this function, the new point is inserted exactly on the 
same position as point no.1. In this way a closed contour is created. 
Areas with closed contours can be filled, if necessary. 
If one of these both points, the first or the last one, are moved after-
wards, the contour may not be closed anymore. 

 The selected point can be moved via the arrow keys in the desired direc-
tion. 

To End If this function is activated, the selected point is moved together with all 
subsequent points via the arrow keys. 

Zoom If this function is activated, the bezier object can be zoomed up and 
down on the screen via the arrow keys. 

1x 

 

 

   

 

10x 

Via this options fields the step width of the arrow key movement can be 
defined.  
1x = 0.1 mm, 10x = 1 mm. 
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Previous 

Next 

To select the next or previous point in the bezier object. 

Number of vectors Via these pop-aup menü the number of vector lines, which connect two 
neighboured points, can be defined. If „1“ is selected, the points are con-
nected via one line only. 

Raw Object It’s possible to modify or move Bezier objects in the weldMARK window 
(via dimension tools). After a modification in the weldMARK window it is 
possible that the Bezier object is positioned outside Bezier window bor-
ders. In this case activate function Raw Object to display the original 
bezier object at its point of origin. 

Snap mouse moves to 
[mm] 

If this function is activated, the point is snapped to a grid (1mm), when 
moving it via mouse. 
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4.5.5 Text objects  
Text objects can be created using either TrueType™ fonts or laser-optimized fonts. For True-
Type™ fonts, the characters are defined by their contour. The contour can be given a fill. For 
laser-optimized fonts, the characters are made up of lines or points. The laser-optimized fonts 
"Stroke" and "SEMI Dot Matrix" are included in the weldMARK® installation. 

Defaults for Text Objects 
This section describes how you can call up and modify the defaults for text objects. The de-
faults affect all new text objects. 
o Select the Objects >Defaults... option from the 

menu. 
o Select the object type Text. 

The adjacent window is opened.  
Refer to the table below for explanations. 

S025

  

Font The character set for all new text objects can be selected. 

Fill spacing The distance between the individual fill lines can be set for all new text 
objects. Entering "0" means that the characters will not be filled. 

Mark object If this function is enabled, the contour lines for the characters will be 
marked. The function is enabled by default. 

Mark fill If this function is enabled, the character fill is marked. The function can 
only be enabled if a fill spacing of > 0 has been set. 
This function is disabled by default. 
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Adding a Text  Object 
o Select the Objects >Add >Text option 

from the menu. 
The adjacent window is opened.  
Refer to the table below for explanations. 

S026

 

(1) Character set to be used for the new text object. 

(2) Content of the new text object (string). 

   
Text alignment buttons for multi-line texts (left aligned, centered, right 
aligned). 

 
The Windows character map is called up to make it easier to enter spe-
cial characters. (  on page 60, Unicode character map ) 

Add The new object is inserted in the center of the workspace. 
 

Properties of a text object 
Text objects are assigned properties that determine how they are displayed on the screen and 
the behavior during laser processing. These properties are divided up as follows: 

Profile  The object is assigned a marking profile. The pa-
rameters of this profile can be changed. 

 on page 108, Using pro-
files 

Settings Various settings can be made for the object.  on page 55, Settings for a 
text object. 

String  Content and formatting of the text object.  on page 57, String for a 
text object 

Source The content of text objects can be changed dy-
namically based on various rules. 

 on page 57, String rules 

Fill  A fill can be applied to the object.  on page 69, Object fill 

Notes A note can be assigned to the object.  on page 28, Notes 

Ext. Control A marking condition can be applied to the object. If 
the external control is activated, external signals 
determine whether the object is marked or skipped. 

 on page 29, External Con-
trol 

 
New text 
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Settings for a text object 
Every text object is assigned specific settings that can be called up and, if necessary, modi-
fied as follows: 
o Right click on a text object. 
o Select the Properties... option from the 

menu.  
o Select the Settings tab. 

The adjacent window is opened.  
Refer to the table below for explanations. 

S023

 

Name  The object name entered in this text box is used to list the object in the 
Object Manager. The name also appears in all information and dialog 
boxes relating to that object. 

On screen color  The color selection list can be used to select one of the preset colors to 
display the object on screen. 

Mark style The text object is marked in either a vector-based or dot matrix style. 
Additional settings are available for the "dot matrix" marking style. (  on 
page 56, Additional settings for dot matrix fonts).  

Mark object If this function is enabled, the contour lines (shape) of the characters will 
be marked. The function is enabled by default. 

Mark fill If this function is enabled, the character fill is marked. The function can 
only be enabled for TrueType fonts and if a fill has been set for the ob-
ject. 
This function is disabled by default. 

Display vector jumps If this function is enabled, the entire sequence of movements is dis-
played on the screen, including the times in which the laser is deacti-
vated while moving to the next vector to be marked (vector jumps). The 
function is disabled by default. 

Mark to If more than one control card is installed, this drop-down menu can be 
used to set the control card to be used for marking the object. 
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Additional settings for dot matrix fonts 
Dot matrix fonts are special character sets in which the characters are made up of individual 
dots. The character set SEMI Dot Matrix is included in the weldMARK® installation. Special 
settings are available for this kind of character set: 
o Right click on a text object. 
o Select the Properties... option from the 

menu.  
o Select the Settings tab. 
o Select the marking style Dot. 

The adjacent window is opened.  
Refer to the table below for explanations. 

S037

 

Dot spacing Distance between the marking points in the X and Y axis. 

Dot display size Dot size on the screen. 
This parameter has no influence on the actual marking. 

Pulse on time Laser activation time per pulse. 

Pulse off time Laser deactivation time between 
the individual pulses (with > 1 
pulses). 

Pulses per dot Number of pulses emitted per 
marking point. 

Depending on the material, the 
combination of these settings de-
termines the size of the marking 
points. 

Example: 

OBJ 9  
Screen display for a dot matrix font with vector jumps shown.
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String for a text object 
The content of a text object consists of a string. In turn, this string can consist of any combina-
tion of letters and numbers. weldMARK® differentiates between one-line and multi-line strings 
(with paragraph breaks) and provides different functions in each case. 

Content and display options for multi-line text objects 
o Right click on a multi-line text object. 
o Select the Properties... option from the 

menu.  
o Select the String tab. 

The adjacent window is opened.  
Refer to the table below for explanations. 

S027

 

[1] Font for text object. 

[2] Content of the text object (string). 

  
The font styles "Bold" and/or "Italic" can be applied to text objects with 
True Type Fonts. 

   
Text alignment buttons for multi-line texts (left aligned, centered, right 
aligned). 

 
The Windows character map is called up to make it easier to enter spe-
cial characters. (  on page 60, Unicode character map ) 

Character kerning The spacing between the individual characters can be changed. Positive 
values increase the spacing, negative values reduce it. A value of "0" 
uses the kerning defined in the character set. 

Character width growth The width of the individual characters can be changed. Positive values 
increase the character width, negative values reduce it. Entering "0" 
means that the character width defined in the character set is used. 

Line spacing The spacing between the lines can be changed. Positive values increase 
the spacing, negative values reduce it. Entering "0" means that the line 
spacing defined in the character set is used. 
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Content and display options for single line text objects 
o Right click on a single line text object. 
o Select the Properties... option from the 

menu.  
o Select the String tab. 

The adjacent window is opened.  
Refer to the table below for explanations. 

S028

 

[1] Font for text object. 

[2] Content of the text object (string). 

  
You can apply the styles "Bold" and/or "Italic" to the text object. 

 
The Windows character map is called up to make it easier to enter spe-
cial characters. (  on page 60, Unicode character map ) 

String orientation You can choose between Horizontal, Vertical, Radial - variable and Ra-
dial – fixed. 
If a 4-axis motor control card is installed, the additional option circumfer-
ential is also available. 

Character kerning The spacing between the individual characters can be changed. Positive 
values increase the spacing, negative values reduce it. A value of "0" 
uses the kerning defined in the character set. 

Character width growth The width of the individual characters can be changed. Positive values 
increase the character width, negative values reduce it. A value of "0" 
uses the character width defined in the character set. 

 

 

 

 

 

 

 

 

 

 

Horizontal Vertical Radial - variable 
Clockwise (CW 
fit) 

Radial - variable  
Anticlockwise 
(CCW fit) 

Circumferential 

 
 on page 59, Additional setting options for radial text 
 on page 59, Additional setting options for circumferential text 
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Additional setting options for radial text 
S038

S039

Radial - variable  Radial - fixed 
 

Radial orientation The text can run clockwise (CW fit) or anticlockwise (CCW fit). 

Character width growth The width of the individual characters can be changed. Positive values 
increase the character width, negative values reduce it. Entering "0" 
means that the character width defined in the character set is used. 

 

Additional setting options using keyboard commands 
The following settings can be made exclusively using keyboard commands when the Proper-
ties and Dimensions windows are closed: 

Radius  Make sure that the required text object is selected. Hold down the ALT 
key and use the Up and Down arrow keys to enlarge or reduce the object 
radius. 

Rotation  Make sure that the required text object is selected. Hold down the ALT 
key and use the Right and Left arrow keys to rotate the object. 

 

Additional setting options for circumferential text  
The Circumferential option is only available if the optional 4-axis motor control card is in-
stalled. The following additional settings are available: 

Part radius  Radius of the area to be marked. 

Index step speed Step speed of the motor. 

Index step delay Delay between the movement of the motor and marking of a character. 
This allows the motor to come to rest before the marking is performed. 

Reset indexer to: Enable this function to return the motor to a defined start position before 
processing an object. 
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Unicode character map  
The Windows Unicode character map enables you to insert any characters in a font, particu-
larly special characters, into the string of characters in a text object. 
o Right click on a text object. 
o Select the Properties... option from the 

menu. 
o Select the String tab. 
o Click on the Character Map icon. 

The adjacent window is opened.  
Refer to the table below for explanations.

S103

 

Font This selection box can be used to select a font. 

Select Clicking on this button adds the selected character to the list of Charac-
ters to copy. 

Characters to copy  This field lists the selected characters. 

Group by  This selection box can be used to display a subgroup of characters from 
the selected font. 

Copy Clicking on this button copies the characters in the Characters to copy 
list to the clipboard. 

 

 
Character Map 
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4.5.6 Barcode objects  
Barcode objects represent numerical and/or alphanumeric characters as a machine readable 
graphic. The following barcode objects are supported by weldMARK®:  

Code 39, Extended Code 39, HIBC  UPC A, UPC E  

CodaBar  EAN 8, EAN 13, BookLan  

Code 93  DataMatrix (ECC200)  

Code 128, EAN/UCC 128  Denso QR code  

Interleaved 2 of 5 (ITF)  PDF 417  

POSTNET (Zip+4, Zip+6)   
 

Defaults for barcode objects 
This section describes how you can call up and modify the defaults for barcode objects. The 
defaults affect all new barcode objects. 
o Select the Objects >Defaults... option from the 

menu. 
o Select the object type 1D Barcode or 2D 

Barcode. 
The adjacent window is opened.  
Refer to the table below for explanations. 
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Fill spacing When marking a barcode object, each bar or cell in a barcode is created 
with single lines. Via the value for Fill spacing the distance of these fill 
lines can be set. A value of "0" means that the bars will not be filled. 

Mark object If this function is enabled, the contour lines for the bars or cells will be 
marked. This function is disabled by default. 

Mark fill If this function is enabled, the bar or cell fill is marked. 
This function is enabled by default. 

Invert barcode Enabling this function creates a negative of the original barcode. This 
function is disabled by default. 
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Adding a barcode object 
o Select the Objects >Add >Barcode option 

from the menu.  
The adjacent window is opened. 

o Select the required barcode type. 
o Enter the necessary data for the barcode.
o Click on the Add button. 

A new barcode object is inserted in the 
center of the workspace. 

S030

 

Properties of a barcode object 
Barcode objects are assigned properties that determine how they are displayed on the screen 
and the behavior during laser processing. These properties are divided up as follows: 

Profile  The object is assigned a marking profile. The pa-
rameters of this profile can be changed. 

 on page 108, Using pro-
files 

Settings Various settings can be made for the object.  on page 63, Settings for a 
barcode object 

String  Content of the barcode object.  on page 65, String for a 
barcode object 

Source The content of barcode objects can be changed 
dynamically based on various rules. 

 on page 71, String rules 

Tuner  The barcode can be adapted for individual require-
ments. 

 on page 66, Tuner values 
for barcode objects 

Fill  A fill can be applied to the object.  on page 69, Object fill 

Notes A note can be assigned to the object.  on page 28, Notes 

Ext. Control A marking condition can be applied to the object. If 
the external control is activated, external signals 
determine whether the object is marked or skipped. 

 on page 29, External Con-
trol 

 
New barcode 
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Settings for a barcode object 
Every barcode object is assigned specific settings that can be called up and, if necessary, 
modified as follows: 
o Right click on a barcode object. 
o Select the Properties... option. 
o Select the Settings tab. 

The adjacent window is opened.  
Refer to the table below for explanations. 

S033

 
Settings 

Name  The object name entered in this text box is used to list the object in the 
Object Manager. The name also appears in all information and dialog 
boxes relating to that object. 

On screen color  The color selection list can be used to select one of the preset colors to 
display the object on screen. 

Mark style  Barcode objects can be marked using vectors, dots or circle dots. 
 

 on page 64, Settings for "dot" mode 
 on page 64, Settings for "Circle dots" mode 

Mark object  If this function is enabled, the contour lines for bars or cells will be 
marked. This function is disabled by default. 

Mark fill  If this function is enabled, the bar or cell fill is marked. 
This function is enabled by default. 

Display vector jumps If this function is enabled, the entire sequence of movements is dis-
played on the screen, including the times in which the laser is deacti-
vated while moving to the next vector to be marked (vector jumps). The 
function is disabled by default. 

Mark to If more than one control card is installed, this drop-down menu can be 
used to set the control card to be used for marking the object. 
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Settings for "dot" mode 

Dot spacing Distance between the marking points in the X and Y axis. 

Dot display size Dot size on the screen. 
This parameter has no influence on the actual marking. 

Pulse on time Laser activation time per pulse. 

Pulse off time Laser deactivation time between the indi-
vidual pulses (with > 1 pulses). 

Pulses per dot Number of pulses emitted per marking 
point. 

Depending on the mate-
rial, the combination of 
these settings determines 
the size of the marking 
points. 

Show and mark cell out-
lines 

If this function is enabled, the outlines of the bars will be displayed and 
marked. 

 
Settings for "Circle dots" mode 

Circle spacing The distance between two adjacent marking circles.  

Number of sides Each circle is made up of a number of lines. The more lines, the more 
rounded the circle appears. The number of sides determines how many 
lines make up each circle dot. 

Circle diameter The diameter of a marking circle. 

Show and mark cell out-
lines 

If this function is enabled, the outlines of the bars will be displayed and 
marked. 
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String for a barcode object 
o Right click on a barcode object. 
o Select the Properties... option. 
o Select the String tab. 
o The adjacent window is opened.  

Refer to the table below for explanations. 
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Barcode string Content of the barcode object. 

If this function is enabled, in addition to the barcode the associated string 
is marked in plain text. 

Font Font for the string. 

String position The string can be positioned below, above to the left 
or to the right of the barcode. 

String orientation The alphanumeric string can be rotated in 90° incre-
ments. 

String height The height of the characters relative to the height of 
the barcode can be set. 

Mark human readable 
text string 

Distance from 
barcode 

The distance between the string and the barcode can 
be set relative to the height of the barcode. 
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Tuner values for barcode objects 
The tuner values allow you to adapt a barcode object to individual requirements. Some bar-
code types require special options and tuner settings. The tuner values in the following exam-
ple represent the values for barcode type “Code 39”. Please refer to the respective barcode 
explanations for non-listed tuner values. 
o Right click on a barcode object. 
o Select the Properties... option from the 

menu. 
o Select the Tuner tab. 

The adjacent window is opened.  
Refer to the table below for explanations. 
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Bar width reduction  The bar width can be adjusted between -99% and 99%. A positive value 
reduces the bar width and a negative value increases it. 

Narrow/Wide ratio Ratio of dark and light areas in the barcode (the value must be an integer 
between 20 and 30). 

Add check character Enabling this function adds a check character to the barcode. 

Enabling this function creates a negative of the original barcode. Invert barcode  

Quiet zone/width The width of the quiet zone can be set relative to 
the barcode width. 
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4.5.7 Drill objects  
When executing drill objects, the laser is moved to the specified co-ordinates and activated for 
a set time. Drill objects consist of individual dots arranged in rows and columns. Drill objects 
are used for perforating or drilling through a workpiece, for example. 

Adding a drill object 
o Select the Objects >Add > Drill... option from 

the menu.  
The adjacent window is opened.  
Refer to the table below for explanations.  

S031

 
 

Columns 

Rows 

Number of (dot) rows and columns that the drill object will consist of. 

# points  Number of dots that the drill object consists of. Note that a value of "1" 
creates a single dot. For precision setting, a number of points that is less 
than the product of the rows and columns can be set. 

Pulses per dot Number of pulses emitted per marking point. 
 

Properties of a drill object 
Drill objects are assigned properties that determine how they are displayed on the screen and 
the behavior during laser processing. These properties are divided up as follows: 

Profile  The object is assigned a marking profile. The pa-
rameters of this profile can be changed. 

 on page 108, Using pro-
files 

Settings Various settings can be made for the object.  on page 68, Settings for a 
drill object 

Notes A note can be assigned to the object.  on page 28, Notes 

Ext. Control A marking condition can be applied to the object. If 
the external control is activated, external signals 
determine whether the object is marked or 
skipped. 

 on page 29, External Con-
trol 

 
New drill object 
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Settings for a drill object 
Every drill object is assigned specific settings that can be called up and, if necessary, modified 
as follows: 
o Right click on a drill object. 
o Select the Properties... option from the 

menu. 
o Select the Settings tab. 

The adjacent window is opened.  
Refer to the table below for explanations. 
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Name  The object name entered in this text box is used to list the object in the 
Object Manager. The name also appears in all information and dialog 
boxes relating to that object. 

On screen color  The color selection list can be used to select one of the preset colors to 
display the object on screen. 

Dot display size Dot size on the screen. 
This parameter has no influence on the actual marking. 

Pulse on time Laser activation time per pulse. 

Pulse off time Laser deactivation time between 
the individual pulses (with > 1 
pulses). 

Pulses per dot Number of pulses emitted per 
marking point. 

Depending on the material, the 
combination of these settings de-
termines the size of the marking 
points. 

Mark object Enabling this function means that the object will be marked. The function 
is enabled by default. 

Display vector jumps  If this function is enabled, the entire sequence of movements is dis-
played on the screen, including the times in which the laser is deacti-
vated while moving to the next vector to be marked (vector jumps). The 
function is disabled by default. 

Rows  Number of rows of dots in the drill object. 

Columns  Number of columns of dots in the drill object. 

# of points  Number of dots that the drill object consists of. The number of dots can 
be less than the product of Rows and Columns. 

Mark to If more than one control card is installed, this drop-down menu can be 
used to set the control card to be used for marking the object. 
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4.6 Object fill 
weldMARK® enables areas of an object to be given a fill. Only completely enclosed areas of 
polygon objects (characters of text objects, polygon or rectangle objects, enclosed Bezier 
objects, barcode objects or imported vector graphics) can be filled. The exceptions are bitmap 
objects, laser optimized fonts, dot matrix fonts and drill objects. 
Overlapping objects can not be given a fill. 
The fill is created by densely packed lines that can be identified as hatching with a larger 
spacing. 
 

  
Empty object Filled object 

 
The optimum spacing between the individual lines in a fill depends on the wavelength of the 
laser, the spot size, the material and other factors. The set line spacing is saved along with 
the object and remains unchanged even if the size of the object is changed. 
The examples below show different fill spacings: 
 

  
Fill spacing = 150 bits Fill spacing = 30 bits 

  
In addition to parallel lines, a crosshatch fill with different angles is available: 
 

   
Crosshatch with 0 and 90 degrees Crosshatch with –45 and +45 degrees 

Via the „Offset“ option a distance between the object filling and the object outline can be de-
fined: 

 
 
Object filling with a distance to the object outline 
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 Setting the object fill 
The fill for a selected object is activated and set as follows: 
o Right click on the object to be filled. 
o Select the Properties... option. 
o Fill tab. 

The adjacent window is opened.  
Refer to the table below for explanations. 
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If this function is enabled, all closed paths in the selected object are 
filled. 

 Parallel lines 

 Crosshatch 

 Parallel lines, bidirectional 

Style  

Crosshatch+Bidirectional 

Meander Only for barcode objects with bidirectional hatches (not for 2D barcodes): 
The filling of the objects are marked in one go, i.e. 
without switching off of the laser between end and 
start point of the single lines. 

Fill spacing Spacing of the fill lines. 

Offset This option enables an improvement of the marking 
quality of a filled object. The laser beam creates 
rounded start and end dots with the diameter of the 
laser spot on each fill line. This causes an waved 
appearance of the object outline. The outline is 
straightened by an additional marking of the outline 
itself. 
Because the outline overlaps the start and end points 
of the filling lines, these areas are marked twice. This 
can be prevented by an offset, i.e. a distance be-
tween the outline and the filling lines. 

Slope 1 Hatching angle for parallel lines. 

Fill all closed paths in 
object 

Slope 2 Hatching angle for crosshatch. 
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4.7 String rules 
The strings on which text and barcode objects are based can be changed dynamically during 
execution of the job. The content of the string is adjusted at regular intervals according to the 
selected string rule. 
The string rule for a text or barcode object can be called up and, if necessary, modified as 
follows: 
o Right click on a text or barcode object. 
o Select the Properties... option from the 

menu.  
o Select the Source tab. 

The adjacent window is opened. The table 
below contains an overview of the avail-
able string rules. 
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Use current string The content of the String tab acts as the source for the string. This is the 
default setting. 

Use TextMerge  The source of the string is a linked text file. 
 on page 72, "Use TextMerge" string rule (one line objects) 
 on page 73, "Use TextMerge" string rule (multi-line objects) 

Use AutoDate  Depending on the setting, the string will either consist of the current date, 
the current time or the current shift code. 

 on page 74, "Use AutoDate" string rule 

Supply string at 
start 

The string must be entered by the user before starting each job. This 
entry is then valid until the end of the job. 

 on page 76, "Supply string at start" string rule 

Supply string every 
mark 

The string must be entered by the user each time the object is marked. 
 on page 76, "Supply string every mark" string rule 

Serialize w/current 
start value 

The content of the string is changed in specified increments. The content 
of the String tab is used as the start value. 

 on page 77, "Serialize w/current start value" string rule 

Serialize 
w/supplied start 
value 

The content of the string is changed in specified increments. The user is 
prompted to enter a start value. 

 on page 78, "Serialize w/supplied start value" string rule 

Get string from 
memory buffer  

The content of one of the ten weldMARK® buffers is used as the source 
for the string. 

 on page 79, "Get string from memory buffer" string rule 
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Custom string The content of the string is determined by a formatting code. 
 on page 80, "Custom string" string rule 

 
The range of options available is reduced for multi-line text objects. 
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4.7.1 "Use TextMerge" string rule (one line objects)  
This rule enables the strings for one line text or barcode objects to be loaded from a merge 
file. A simple text file with the extension ".txt" is used as the merge file. Each string in the 
merge file must be completed with a line break (Enter key). This also applies to the last line in 
the merge file.  
The parameters of the TextMerge function can be set as follows for one line objects: 
o Right click on a one line text or barcode 

object. 
o Select the Properties... option from the 

menu.  
o Select the Source tab. 
o Select the Use TextMerge string rule. 

The adjacent window is opened.  
Refer to the table below for explanations. 
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Justify With strings of different lengths, this function aligns the strings with the 
selected point in the original string (left, right, centered / top, center,  
bottom). 

Restart automatically If this function is enabled, the merge file will be re-processed as soon as 
its end has been reached. 

Update string If this function is enabled, the merge file will be read again before execut-
ing. 

MergeFile  The specified text file is completely loaded when starting the job. For 
each marking operation, the string for the text or barcode object is over-
written with the next line from the merge file. If the job is ended, weld-
MARK® sets a bookmark in this text file to indicate the last item proc-
essed. 

New 

Edit 

Browse... 

The merge file can be created, searched, loaded and edited in weld-
MARK®. 

# objects in group Number of text or barcode objects in current job that read their string 
from the same merge file. The value entered corresponds to the incre-
ment for reading the lines: For each marking operation, lines in the 
merge file are skipped corresponding to the number of objects in the 
group. 

Start line Number of the first line to be read from the merge file. 
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4.7.2 "Use TextMerge" string rule (multi-line objects)  
This rule enables the strings for multi-line text or barcode objects to be loaded from a merge 
file. A simple text file with the extension ".txt" is used as the merge file. Each string in the 
merge file must be completed with a line break (Enter key). This also applies to the last line in 
the merge file. 
The parameters of the TextMerge function can be set as follows for multi-line objects: 
o Right click on a multi-line text or barcode 

object. 
o Select the Properties... option from the 

menu.  
o Select the Source tab. 
o Select the Use TextMerge string rule. 

The adjacent window is opened.  
Refer to the table below for explanations. 
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MergeFile  The specified text file is completely loaded when starting the job.  
For each marking operation, the string for the text or barcode object is 
overwritten with the next lines from the MergeFile. If the job is ended, 
weldMARK® sets a bookmark in this text file to indicate the last item 
processed. 

Restart automatically If this function is enabled, the merge file will be re-processed as soon as 
its end of file has been reached. 

Update string If this function is enabled, the merge file will be read again before execut-
ing. 

New 

Edit 

Browse... 

The merge file can be created, searched, loaded and edited in  
weldMARK®. 
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4.7.3 "Use AutoDate" string rule 
This rule enables text or barcode objects to be marked with the current date, the current time 
or the current shift code. This information is derived from the Windows system clock and is 
updated for each marking operation. 
o Right click on a one line text or barcode 

object. 
o Select the Properties... option from the 

menu.  
o Select the Source tab. 
o Select the Use AutoDate string rule. 

The adjacent window is opened.  
Refer to the table below for explanations. 
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Justify  With strings of different lengths, the strings are aligned with the selected point in 
the original string (left, right, centered). 

Format Format selection for the AutoDate string. The available AutoDate formats are as 
follows (example date 15th January 2006): 

 Format Output 

 YYMMDD 060115 

 MM/DD/YY 01/15/06 

 DD/MM/YY 15/01/06 

 Month DD, YYYY January 15, 2006 

 DD Month, YYYY 15 January, 2006 

 YWW 602 (WW: Week number) 

 YMD 61E (single digit alphanumeric values for year, month and 
day. Sequence: 1,2,3...9,0,A,B,C...) 

 DDD  015 (three digit value for day of the year) 

 DDDY  0156 (three digit value for day of the year and single digit 
value for the year) 

 YY 06 

 Shift code See next section. 

 DDMY 1516 

 HH:MM:SS 11:55:00 
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4.7.4 "Shift code" string format 
This format is part of the Use AutoDate string rule (  on page 74, "Use AutoDate" string rule). 
If this format is selected, the current shift code is applied to the object as a string for each 
marking operation. The information is derived from the Windows system clock. 
o Right click on a one line text or barcode 

object. 
o Select the Properties... option from the 

menu.  
o Select the Source tab. 
o Select the Use AutoDate string rule. 
o Select the Shift code format. 

The adjacent window is opened.  
Refer to the table below for explanations. 
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These check boxes can be used to activate up to five shifts. 

Start time  

Stop time  

These fields are used to define the start and end times for 
each shift. If the shifts overlap, the first permissible shift is 
used. The remaining shifts are ignored. If there are peri-
ods of time that are not assigned to an active shift, a "?" is 
output. 
If a shift includes the time 0:00 (change of date), it must 
be split into two sections with the same shift code. 

Shift 1 … Shift 5 

String to mark These fields can be used to enter the shift codes to be 
marked with the laser. 
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4.7.5 "Supply string at start" string rule 
If this rule is selected, each time a job is started the user is prompted to enter a string for the 
text or barcode object. This string is then used until completion of that job. 
o Right click on a one line text or barcode 

object. 
o Select the Properties... option from the 

menu.  
o Select the Source tab. 
o Select the Supply string at start string rule.

The adjacent window is opened.  
Refer to the table below for explanations. 
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Justify  With strings of different lengths, the strings are aligned with the selected point in the 
original string (left, right, centered). 

 

4.7.6 "Supply string every mark" string rule 
If this rule is selected, before marking the object the user is prompted to enter a string for the 
text or barcode object. The string entered is only used for one marking operation. 
o Right click on a one line text or barcode 

object. 
o Select the Properties... option from the 

menu.  
o Select the Source tab. 
o Select the Supply string every mark string 

rule. 
The adjacent window is opened.  
Refer to the table below for explanations. 
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Justify With strings of different lengths, the strings are aligned with the selected point in the 
original string (left, right, centered). 
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4.7.7 "Serialize w/current start value" string rule 
If this rule is selected, the value of a text or barcode object is automatically increased or re-
duced by a particular value.  
When starting the job, the string used to save the job is used as the start value. 
o Right click on a one line text or barcode 

object. 
o Select the Properties... option from the 

menu.  
o Select the Source tab. 
o Select the Serialize w/current start value 

string rule. 
The adjacent window is opened.  
Refer to the table below for explanations. 
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Justify  With strings of different lengths, the strings are aligned with the selected 
point in the original string (left, right, centered). 

Increment Sets the increment by which the string will be changed. A positive value 
increases the value of the string, a negative value reduces it. Both letters 
and numbers can be incremented, e.g. 0001A is increased to 0001B. 
Note that an arrangement of letters is only permissible for ANSI text. It is 
possible that Unicode text consisting of letters will not be incremented 
correctly. Leading zeroes are retained. 

Batch Batch size for serialization. The string is only incremented when the 
number of markings specified under Batch has been performed. 
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4.7.8 "Serialize w/supplied start value" string rule 
If this rule is selected, the value of a text or barcode object is automatically increased or re-
duced by a particular value. 
When starting the job the user is prompted to enter a string as the start value. 
o Right click on a one line text or barcode 

object. 
o Select the Properties... option from the 

menu.  
o Select the Source tab. 
o Select the Serialize w/supplied start value 

string rule. 
The adjacent window is opened.  
Refer to the table below for explanations. 
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Justify With strings of different lengths, the strings are aligned with the selected 
point in the original string (left, right, centered). 

Increment Sets the increment by which the string will be changed. A positive value 
increases the value of the string, a negative value reduces it. Both letters 
and numbers can be incremented, e.g. 0001A is increased to 0001B. 
Note that an arrangement of letters is only permissible for ANSI text. It is 
possible that Unicode text consisting of letters will not be incremented 
correctly. Leading zeroes are retained. 

Batch  Batch size for serialization. The string is only incremented when the 
number of markings specified under Batch has been performed. 
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4.7.9 "Get string from memory buffer" string rule  
This rule enables the strings for text and barcode objects to be read from one of the ten 
weldMARK® buffers immediately prior to the marking operation. The content of the buffer can 
constantly be changed using an external host program (  on page 181, Remote interface). 
o Right click on a one line text or barcode 

object. 
o Select the Properties... option from the 

menu.  
o Select the Source tab. 
o Select the Get string from memory buffer 

string rule. 
The adjacent window is opened.  
Refer to the table below for explanations. 
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Justify With strings of different lengths, the strings are aligned with the selected 
point in the original string (left, right, centered). 

Buffer index  Number of the weldMARK® memory buffer to be used to obtain the data. 

Buffer contents Current content of the weldMARK® buffer selected under Buffer index. 
When the application is started, the buffers are set to a value of "?". 
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4.7.10 "Custom string" string rule  
This rule enables the string for the text or barcode object to be created using a custom string. 
o Right click on a one line text or barcode 

object. 
o Select the Properties... option from the 

menu.  
o Select the Source tab. 
o Select the Custom string string rule. 

The adjacent window is opened.  
Refer to the table below for explanations. 
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Justify  With strings of different lengths, the strings are aligned with the selected 
point in the original string (left, right, centered). 

Format specifier string Enter the custom string to be used to create a string for the object 
(see table below). 

 

Code Code example Text created for string 

%A  Abbreviated day of the week (Mon, Tue, Wed, Thu, Fri, Sat, Sun) 

%B  Abbreviated month (Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, 
Oct, Nov, Dec) 

%C  Date and time (MM/DD/YY HH:MM) 

%D  Day of the month (01 - 31) 

%H  Hour (00 - 23) 

%h  Hour (00 - 12) 

%J  Day of the year (001 - 366) 

%K  Month code (1 - 9, O, N, D) 

%L  Last digit of year (0 - 9) 

%M  Month (01 - 12) 

%N  Minutes (00 - 59) 

%O  Ascending numerical value. 
Starts with a value of "1" at the beginning of the process. 

%o  Same as code %O.  
After restart, the last used numerical value will be used as start 
value. 

%P  AM or PM 

%Q# %Q1 The string is copied from the weldMARK® buffer (# 1-10). 

%R  Week (01-53). Week "01" is the week that includes 1st January. 
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Code Code example Text created for string 

%r  Week (01-53). Week "01" is the week that includes the first Thurs-
day of the new year. 

%S,d,s,i,b %S,9,1,1,1 S = Consecutive number 
d = End number 
s = Start number 
i = Increment 
b = batch  
 
Note:  Only integer values are supported.  
 The parameters "i" and "b" must be positive. 

%s  Same as code %S.  
After restart, the last used numerical value will be used as start 
value. 

%T  Time (HH:MM) 

%V''  %V'RAYLASE' Any text can be entered here. The text must be placed between 
quotation marks ("RAYLASE" in the code example). 

%W  Day of the week (coding: 1 = "Sunday" ... 7 = "Saturday") 

%w  Day of the week (coding: 1 = "Monday" ... 7 = "Sunday") 

%X# %X5 A particular number of spaces can be inserted (5 spaces in the 
code example). 

%Y  Year (00 - 99) 
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5 TOOLS FOR EDITING MARKING OBJECTS  
weldMARK® provides the following tools for editing marking objects: 

Align...  Objects can be aligned relative to one 
another. 

 below, Aligning objects 

Dimensions... Objects can be positioned, scaled, ro-
tated or skewed. 

 below, The "Dimensions..." tool-
box 

Grid/Guidelines The grid and the guidelines are used to 
make it easier to align objects on the 
screen. Their properties can be set. 

 on page 89, Setting the gridlines 
 on page 90, Editing the guide-
lines 

Zoom tools  The display size of the workspace on the 
screen can be enlarged or reduced. 

 on page 92, Using the zoom 
tools 

5.1 Aligning objects 
The Align... tool enables objects to be aligned relative to one another. Objects are always 
aligned with the last selected object. 
o Select the objects you want to align. 
o Select the Tools >Align... option from the 

menu. 
The adjacent window is opened.  
Refer to the table below for explanations. 
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Top, Center, Bottom 

Left, Center, Right 

These check boxes allow you to specify the required vertical and hori-
zontal alignment of the objects with one another. 

Preview 

Reset 

Clicking on this button displays the expected result of the alignment. The 
alignment can then either be reversed by clicking on Reset or confirmed 
by clicking on OK. 

5.2 The "Dimensions..." toolbox 
The "Dimensions" toolbox contains the following tools for editing marking objects: 

Position  on page 83, Positioning objects 

Scale  on page 83, Scaling and mirroring objects 

Size  on page 84, Changing the object size 

Rotate  on page 86, Rotating objects  

Move to Folder...  on page 87, Nudging objects 

Skew  on page 87, Skewing objects 
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5.2.1 Positioning objects  
The Position tool enables you to display and change an object's current position. 
o Select a marking object. 
o Select the Objects >Dimensions... option from the menu. 
o Select the Position tool. 

The adjacent window is opened.  
Refer to the table below for explanations. 
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Position The current position of the selected object is shown in the two input boxes. 
The specified position can be overwritten with your required target position. 
The data relates to the lower left corner of the object.  

Center Clicking on this button positions the selected object in the center of the work-
space. 

Apply Clicking on this button applies the settings made to the selected object. 

Apply to Duplicate Clicking on this button copies the selected object and applies the changed 
settings to the copy. 

5.2.2 Scaling and mirroring objects 
The Scale tool enables you to scale objects by a specified factor and, if required, to mirror 
them. 
o Select a marking object. 
o Select the Objects >Dimensions... option from the menu. 
o Select the Scale tool. 

The adjacent window is opened.  
Refer to the table below for explanations. 
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Scale The required scaling factor is specified in this input box. 

Proportional If this function is enabled, the object is scaled by the same factor horizontally 
and vertically. 

Mirror Clicking on this button mirrors the selected object horizontally or vertically. 

Apply Clicking on this button applies the settings made to the selected object. 

Apply to Duplicate Clicking on this button copies the selected object and applies the changed 
settings to the copy. 

 
A separate tool is available for fixed radial text objects (  on page 85, Changing the object 
size (radial text - fixed)).  
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5.2.3 Changing the object size 
The Size tool enables you to change the width and height of objects by entering the required 
values. 
o Select a marking object. 
o Select the Objects >Dimensions... option from the menu. 
o Select the Size tool. 

The adjacent window is opened.  
Refer to the table below for explanations. 
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Size These input boxes display the current width and height of the selected object. 
The values can be changed as required. The change in size is performed 
from the center of the selected object or object group. 

Proportional If this function is enabled, the width and height of the object are changed by 
the same factor horizontally and vertically. Making an entry in one field auto-
matically changes the value in the other field. 

Apply Clicking on this button applies the settings made to the selected object. 

Apply to Duplicate Clicking on this button copies the selected object and applies the changed 
settings to the copy. 

 

Size option for standard and radial text objects 
For standard text objects and for text objects with the Radial display option, in addition to the 
option of changing the size (  above, Changing the object size) the special Constraints func-
tion is available. This function enables an output size differing from the size shown on screen 
to be applied to these objects for the marking process.  
o Select a text or radial text object. 
o Select the Objects >Dimensions... option from the menu. 
o Select the Size tool. 
o Select the Constraints option from the menu. 

The adjacent window is opened.  
Refer to the table below for explanations. 
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Enabling this function allows you to specify the output size of the radial text ob-
ject. 

 

When marking, 
constrain size to 

 

The required output size for the radial text objects can be entered in these 
fields. 

Apply Clicking on this button applies the settings made to the selected object. 

Apply to Dupli-
cate 

Clicking on this button copies the selected object and applies the changed set-
tings to the copy. 

Example: 
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Radial text variable  Option: Constraints 

The red rectangle indicates the 
output size. 

Changing the object size (radial text - fixed) 
Special options are available for changing the size of Radial - fixed type objects. These ob-
jects can also be assigned an output size differing from the size shown on screen for the 
marking process. 
o Select a fixed radial text object. 
o Select the Objects >Dimensions... option from the menu. 
o Select the Size tool. 

The adjacent window is opened. 
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The diameter for the base line of the text can be specified here. 

 
The font size can be specified by entering the x-height and ascender. 

Size 

 
The font size can be specified by entering the descender. 

Constraints Enabling this function allows a different diameter to be selected for the marking 
process. 

Apply Clicking on this button applies the settings made to the selected object. 

Apply to Dupli-
cate 

Clicking on this button copies the selected object and applies the changed set-
tings to the copy. 
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Example: 

 

Radial text - fixed 

5.2.4 Rotating objects 
The Rotate tool enables objects to be rotated by a specified angle.  
o Select a marking object. 
o Select the Objects >Dimensions... option from the menu. 
o Select the Rotate tool. 

The adjacent window is opened.  
Refer to the table below for explanations. 
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Angle This field can be used to enter an angle for rotating the object. 
Positive values = Clockwise rotation 
Negative values = Anticlockwise rotation 

Apply Clicking on this button applies the settings made to the selected object. 

Apply to Dupli-
cate 

Clicking on this button copies the selected object and applies the changed settings 
to the copy. 
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5.2.5 Nudging objects 
The Nudge tool enables objects to be moved by a specified amount. 
o Select a marking object. 
o Select the Objects >Dimensions... option from the menu. 
o Select the Nudge tool. 

The adjacent window is opened.  
Refer to the table below for explanations. 
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Nudge These input boxes can be used to specify values for the required movement of 
the object in a horizontal and vertical direction. 

Apply Clicking on this button applies the settings made to the selected object. 

Apply to Dupli-
cate 

Clicking on this button copies the selected object and applies the changed set-
tings to the copy. 

5.2.6 Skewing objects 
The Skew tool enables objects to be skewed by a specified angle. 
o Select a marking object. 
o Select the Objects >Dimensions... option from the menu. 
o Select the Skew tool. 

The adjacent window is opened.  
Refer to the table below for explanations. 
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Skew These input boxes can be used to specify values for skewing the object. Re-
fer to the example below for details. 

Apply Clicking on this button applies the settings made to the selected object. 

Apply to Duplicate Clicking on this button copies the selected object and applies the changed 
settings to the copy. 
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Example: 

 

 

 

 

 

  
 10 degrees 

 
 10 degrees 

 
This tool is not available for fixed radial text objects. 
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5.3 Grid/Guidelines 
The guidelines and the grid make it easier to align objects on the screen. Their properties can 
be set. 

5.3.1 Grid lines 
The grid is made up of equally spaced horizontal and vertical lines and makes it easier to 
draw and arrange objects. 

Showing and hiding the grid lines 
o Select the View >Grid option from the menu. 

Grid lines are displayed or hidden. 
 

Setting the gridlines 
The grid settings determine the way in which the grid is displayed on screen and the behavior 
of an object if it is placed close to one of the grid lines. 
o Select the Tools >Grid/Guidelines... option 

from the menu. 
The adjacent window is opened. The figure 
shows only the section that is relevant for 
the grid lines.  
Refer to the table below for explanations.  

104a 

 
 
 

Place a horizontal grid 
line every 

Place a vertical grid line 
every 

These input boxes can be used to specify the horizontal and vertical 
spacing between the individual grid lines. 

Show Grid Enabling this function shows the grid lines. 

Snap To Grid If this function is enabled, objects are aligned with the grid lines when 
you move them. 

5.3.2 Guidelines 
The guidelines are made up of horizontal and vertical lines with the spacing of your choice. 
Any combinations of guidelines can be saved and reloaded at a later date. 

Showing and hiding the guidelines 
o Select the View >Guidelines option from the menu. 

The guidelines are displayed or hidden. This function is only available if guidelines are set 
(  on page 90, Editing the guidelines). 

 
Guidelines 

 
Grid 
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Editing the guidelines 
Guidelines can be added, moved and deleted. An unlimited number of guidelines can be in-
serted in the workspace.  
o Select the Tools >Grid/Guidelines... option 

from the menu. 
The adjacent window is opened. The figure 
shows only the section that is relevant for 
the guidelines. 
Refer to the table below for explanations. 
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Restore Guidelines 
when loading job 

Enabling this function saves the guidelines created as part of the job. 

 
o Click on the Setup button. 

The adjacent window is opened.  
Refer to the table below for explanations. 
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Horizontal, Vertical One tab is available for the horizontal guidelines and one for the vertical 
guidelines. 

(1) Input box to specify the position of the guideline to be created. 

Add Clicking on this button adds the new guideline at the position entered. 

(2) List of all guidelines created. 

Move Clicking on this button moves the guideline selected in the list box (2) to the 
position specified in the input box (1). 

Delete Clicking on this button deletes the guideline selected in the list box (2). 

Clear Clicking on this button deletes all horizontal or vertical guidelines. The horizon-
tal and vertical guidelines are not deleted together. 

Show Guidelines Enabling this function shows the guidelines. 

Snap To Guidelines If this function is enabled, objects are aligned with the guidelines when you 
move them. 

Load Preset... Allows saved preset guidelines to be loaded to the active job.  
(  on page 91, Loading preset guidelines). 

Save Preset... All guidelines in a job can be saved as a preset and will then be available for 
use in other jobs (  on page 91, Saving preset guidelines). 

Organize Presets... Allows saved preset guidelines to be renamed or deleted (  on page 91, 
Organizing preset guidelines). 

Clear All Deletes all guidelines in the job. 
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Saving preset guidelines 
All guidelines in a job are referred to as preset guidelines. If you want preset guidelines to be 
available for other jobs, they can be saved as described below. If you only want the guidelines 
to be saved with the current job, you can use the Restore Guidelines when loading job func-
tion (  on page 90, Editing the guidelines). 
o Select the Tools >Grid/Guidelines... option from the 

menu. 
o Click on the Setup button. 
o Click on the Save Preset... button. 

The adjacent window is opened. 

S107

 

OK Once you have entered a name for the preset guidelines, you can save them. 

Skip This button allows the preset guidelines to be saved without a name. This 
overwrites the internal preset guidelines. 

 

Loading preset guidelines 
Saved preset guidelines can be loaded to the active job as described below. This overwrites 
any existing guidelines.  
o Select the Tools >Grid/Guidelines... option from the 

menu. 
o Click on the Setup button. 
o Click on the Load Preset... button. The adjacent 

window is opened. 
o Select the preset guidelines you want to use and 

click on OK. 
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Organizing preset guidelines 
Saved preset guidelines can be renamed or deleted as follows: 
o Select the Tools >Grid/Guidelines... option 

from the menu. 
o Click on the Setup button. 
o Click on the Organize Presets... button. 

The adjacent window is opened. 
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5.4 Using the zoom tools  
Three tools are available for changing the size at which the workspace is displayed. 

Zoom in 
o Click on the Zoom in icon.  
o Hold down the right mouse button and draw a rectangle around the area you want to zoom 

in on. 
 

Zoom out 
o Click on the Zoom out icon. 

The workspace display is reduced in size. 
o To reduce the display size further, click on the Zoom out button again. 
 

Full View 
o Click on the Full View icon. 

The entire workspace is displayed as large as possible. 
 
 

 
Zoom in 

 
Zoom out 

 
Full View 
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Convert to Template

6 TEMPLATES 
A template is an object that cannot be modified and is not actually marked. It is created from a 
marking object. In order to edit a template, it must be converted back into a marking object 
first. Only one template can be created in each job. 
Examples of using a template would include aligning objects or placing additional information 
that is not to be marked in the workspace.  
 

Creating templates 
o Add the object you want to use as a template to your job. 
o Edit the object as required. 
o Select the object. 
o Select the Objects >Convert to Template option from the menu. 

The object converted into a template appears in the Job Manager (Current Job window) as 
a Template and disappears from the Object Manager.  

 

Converting a template into a marking object 
o In the Current Job window, right click on Template and select Convert to Object. 
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7 USING AUTOMATION OBJECTS 
Automation objects allow communication with external applications and control devices. They 
are used to automate processing and the internal weldMARK® processes. weldMARK® pro-
vides the following automation objects: 

Wait for External  
Signal  

This object checks whether a sig-
nal is present at a selected I/O 
port. The marking process is not 
continued until the signal is pre-
sent. 

 on page 95, "Wait for External 
Signal" automation object 

Set I/O Port  This object sets one or more I/O 
ports to "Low" or "High". 

 on page 97, "Set I/O Port" 
automation object 

Insert Time 
Delay  

This object inserts a time delay 
between two objects. The marking 
process is only continued when 
the specified time span has 
elapsed. 

 on page 99, "Insert Time Delay" 
automation object 

Show Messagebox  This object displays a message 
window on the screen during the 
marking process. The process is 
stopped until the user closes the 
message box. 

 on page 100, "Show Message-
box" automation object 

XY Table  This object controls an optional XY 
Table that is connected. 

 on page 102, "XY Table" auto-
mation object 

Rotary Indexer This object controls an optional 
rotary indexer that is connected. 

 on page 104, "Rotary Indexer" 
automation object 

Custom Axis This object controls an optional 
custom axis that is connected. 

 on page 106, "Custom Axis" 
automation object 
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7.1 "Wait for External Signal" automation object 
This object checks whether a signal is present at a selected I/O port. The marking process is 
not continued until the signal is present. 

Defaults for "Wait for External Signal" 
This section describes how the defaults for "Wait for External Signal" type automation objects 
can be called up and changed. The defaults apply to all new automation objects of this type. 
o Select the Objects >Defaults... option from the 

menu. 
o Select the object type Wait for External Signal.

The adjacent window is opened.  
Refer to the table below for explanations. 

S051

 

Use I/ port Preset I/O port to be monitored. 

Message A text can be entered for a message to be displayed during the waiting 
time. 

 

Adding a "Wait for External Signal" object 
o Select the Objects >Add >Automation... option 

from the menu. 
The adjacent window is opened. 

o Select the Wait for External Signal automation 
object type. 

o Add button. 
The automation object is added to the Object 
Manager. 
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Properties 
The automation object is assigned properties, which are classified as follows: 

Settings Various settings can be made for the object.  on page 96, Settings 

Notes A note can be assigned to the object.  on page 28, Notes 
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Wait for  

External Signal 

Settings 
o In the Object Manager, right click on a 

Wait for External Signal type automation 
object. 

o Select the Properties... option from the 
menu. 
The adjacent window is opened.  
Refer to the table below for explanations. 
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Name  The object name entered in this text box is used to list the object in the 
Object Manager. The name also appears in all information and dialog 
boxes relating to that object. 

I/O Port You can select the input port to be checked. 

Message  A text can be entered for a message to be displayed during the waiting 
time. 
The text entered in Defaults... is used if you do not enter anything here. 

(1) The marking process is not started until the start signal is de-assented. 

(2) The marking process is started as soon as the start signal is assented. 

Test Clicking on this button reads the I/O port and displays the result. 
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7.2 "Set I/O Port" automation object 
This object sets the status of one or more I/O ports to "Low" or "High".  

Defaults for "Set I/O Port" 
This section describes how the defaults for "Set I/O Port" type automation objects can be 
called up and changed. The defaults apply to all new automation objects of this type. 
o Select the Objects >Defaults... option from the 

menu. 
o Select the object type Set I/O Port. 

The adjacent window is opened.  
Refer to the table below for explanations. 
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I/O card action The required behavior of the port can be selected. 

Use I/ port You can select the input port to be set. 
  

Adding a "Set I/O Port" object 
o Select the Objects >Add >Automation... option 

from the menu. 
The adjacent window is opened. 

o Select the automation object type Set I/O Port. 
o Add button. 

The automation object is added to the Object 
Manager. 
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Properties 
The automation object is assigned properties, which are classified as follows: 

Settings Various settings can be made for the object.  on page 98, Settings 

Notes A note can be assigned to the object.  on page 28, Notes 
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Set I/O Port 

Settings 
o In the Object Manager, right click on a Set 

I/O Port type automation object. 
o Select the Properties... option from the 

menu. 
The adjacent window is opened.  
Refer to the table below for explanations. 
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Name  The object name entered in this text box is used to list the object in the 
Object Manager. The name also appears in all information and dialog 
boxes relating to that object. 

I/O card action The following actions can be selected: 

 Set Port TRUE The selected port is set to TRUE. 

 Set Port FALSE The selected port is set to FALSE. 

 Pulse Port The selected port is alternately set to FALSE - 
TRUE - FALSE. The time span for the TRUE 
status can be adjusted. 
Note that the value for the time span is only an 
approximate value. 

 SET WORD The word consists of 6 bits, corresponding to 
the six output ports OUT1 to OUT6. Each bit 
sets one output port. 

Use I/O port The output port to be set (  on page 108, Marking object profile). 

Word value This input box is only active if the Set WORD action has been selected. 
A value between 0 and 63 (decimal) can be set. 

Test Clicking on this button sets the I/O port in line with the settings made for 
testing purposes. The set port and the current status are displayed. 
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Insert Time Delay 

7.3 "Insert Time Delay" automation object 
This object inserts a time delay between two objects. The marking process is only continued 
when the specified time span has elapsed. 

Adding an "Insert Time Delay" object 
o Select the Objects >Add >Automation... option from 

the menu. 
The adjacent window is opened. 

o Select the automation object type Insert Time 
Delay. 

o Add button. 
The automation object is added to the Object 
Manager. 
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Properties 
The automation object is assigned properties, which are classified as follows: 

Settings Various settings can be made for the object.  below, Settings 

Notes A note can be assigned to the object.  on page 28, Notes 
 

Settings 
o In the Object Manager, right click on an 

Insert Time Delay type automation object.
o Select the Properties... option from the 

menu. 
The adjacent window is opened.  
Refer to the table below for explanations. 
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Name  The object name entered in this text box is used to list the object in the 
Object Manager. The name also appears in all information and dialog 
boxes relating to that object. 

Delay  Time delay in milliseconds. 

Test Clicking on this button displays a window specifying the current time de-
lay setting.  
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7.4 "Show Messagebox" automation object  
This object displays a message window on the screen during the marking process. The proc-
ess is stopped until the user closes the message box. 

Defaults for "Show Messagebox" 
This section describes how the defaults for "Show Messagebox" type automation objects can 
be called up and changed. The defaults apply to all new automation objects of this type. 
o Select the Objects >Defaults... option from the 

menu. 
o Select the object type Show Messagebox.  

The adjacent window is opened.  
Refer to the table below for explanations. 
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Title  The text that will appear in the title bar of the message window. 

Message  The text that will appear as the message. 
 

Adding a "Show Messagebox" object 
o Select the Objects >Add >Automation... option 

from the menu. 
The adjacent window is opened. 

o Select the automation object type Show 
Messagebox. 

o Add button. 
The automation object is added to the Object 
Manager. 
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Properties 
The automation object is assigned properties, which are classified as follows: 

Settings Various settings can be made for the object.  on page 101, Settings 

Notes A note can be assigned to the object.  on page 28, Notes 
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Show  

Messagebox 

Settings 
o In the Object Manager, right click on a 

Show Messagebox type automation 
object. 

o Select the Properties... option from the 
menu. 
The adjacent window is opened.  
Refer to the table below for explanations. 
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Name  The object name entered in this text box is used to list the object in the 
Object Manager. The name also appears in all information and dialog 
boxes relating to that object. 

Title  The text for the message box title bar can be adjusted. 

Message  The text that will be displayed in the message box can be entered in this 
field. 

Test Clicking on this button displays the message box for testing purposes. 
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XY Table 

7.5 "XY Table" automation object 
This object controls an optional XY Table that is connected. A motor controller card is neces-
sary to control the table (  on page 175, Operating stepper motors). 

 Adding an "XY Table" automation object  
o Select the Objects >Add >Automation... option 

from the menu. 
The adjacent window is opened. 
Select the XY Table automation object. 

o Click on the Add button. 
The automation object is added to the Object 
Manager. 
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Properties 
The automation object is assigned properties, which are classified as follows: 

Settings Various settings can be made for the object.  below, Settings 

Notes A note can be assigned to the object.  on page 28, Notes 
 

Settings 
o In the Object Manager, right click on an 

XY Table type automation object. 
o Select the Settings option from the menu. 

The adjacent window is opened.  
Refer to the table below for explanations. 
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Name  The object name entered in this text box is used to list the object in the 
Object Manager. The name also appears in all information and dialog 
boxes relating to that object. 

Current These fields show the current position of the motor axes. 

Move to These fields can be used to enter an absolute target position, i.e. the 
position to which you want the table to move. 
These fields are only available if the Absolute setting has been selected 
in the Moves are list box. 

Move These fields can be used to enter a relative target position, i.e. the dis-
tance you want the table to move. 
These fields are only available if the Relative setting has been selected 
in the Moves are list box. 

At speed These fields can be used to enter the speed [steps per second] at which 
you want the table to move. 

mm 

Inches 

Units 

Steps 

The distances can be entered in millimeters, 
inches or motor steps. 

The mode for specifying the moves must be selected: 

Absolute The table moves to the position specified under 
Move to. 

Moves are 

Relative The table moves by the values specified under 
Move. 

Go  Clicking on this button performs the specified table movement. 

HOME Clicking on this button moves the table to its home position. 

STOP Stops the movement of the XY table. 
 



Chapter 7 Using automation objects 

104 RAYLASE weldMARK® MN013 / v2.0 

7.6 "Rotary Indexer" automation object 
This object controls an optional rotary indexer that is connected. A motor controller card is 
necessary for this (  on page 175, Operating stepper motors). 

Adding a "Rotary Indexer" automation object 
o Select the Objects >Add >Automation... option 

from the menu. 
The adjacent window is opened. 

o Select the automation object type Rotary Indexer.
o Add button. 

The automation object is added to the Object 
Manager. 
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Properties 
The automation object is assigned properties, which are classified as follows: 

Settings Various settings can be made for the object.  below, Settings 

Notes A note can be assigned to the object.  on page 28, Notes 
 

Settings 
o Right click on the object you want to 

change in the Object Manager. 
o Select the Properties... option from the 

menu. 
The adjacent window is opened.  
Refer to the table below for explanations. 
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Name  The object name entered in this text box is used to list the object in the 
Object Manager. The name also appears in all information and dialog 
boxes relating to that object. 

Current This field shows the current position of the rotary indexer. 

Move to In this field, you can enter an absolute target position, i.e. the position 
you want the rotary indexer to rotate to.  
This field is only available if the Absolute setting has been selected in the 
Moves are list box. 

Move In this field, you can enter a relative target position, i.e. the distance you 
want the axis to rotate by. 
This field is only available if the Relative setting has been selected in the 
Moves are list box. 

At speed This field can be used to enter the speed [steps per second] at which you 
want the axis to rotate. 

Part radius This field is used to enter the radius of the rotating component. The ra-
dius is required to calculate the target position or distance, if this is en-
tered in inches or millimeters. 

Rotate every … process 
cycles 

This field is used to enter the number of process cycles to be performed 
before the axis is rotated.  

mm 

Inches 

Degrees 

Units 

Steps 

The distances can be entered in millimeters, 
inches, degrees or motor steps. 

The mode for specifying the moves must be selected: 

Absolute The axis is rotated to the position specified un-
der Move to. 

Moves are 

Relative The axis is rotated by the value specified under 
Move. 

Go  Clicking on this button performs the specified rotary movement. 

HOME Clicking on this button rotates the rotary indexer to its home position. 

STOP Stops the movement of the rotary indexer. 
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7.7 "Custom Axis" automation object 
This object controls an optional custom axis that is connected. The custom axis can be con-
figured for either linear or rotating applications. A motor controller card is necessary for this 
(  on page 175, Operating stepper motors). 

Adding a "Custom Axis (Z axis)" object  
o Select the Objects >Add >Automation... option 

from the menu. 
The adjacent window is opened. 

o Select the automation object type Custom Axis. 
o Click on the Add button. 

The automation object is added to the Object 
Manager. 
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Properties 
The automation object is assigned properties, which are classified as follows: 

Settings Various settings can be made for the object.  below, Settings 

Notes A note can be assigned to the object.  on page 28, Notes 
 

Settings 
o Right click on the object you want to 

change in the Object Manager. 
o Select the Properties... option from the 

menu. 
The adjacent window is opened.  
Refer to the table below for explanations. 
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Name  The object name entered in this text box is used to list the object in the 
Object Manager. The name also appears in all information and dialog 
boxes relating to that object. 

Current This field shows the current position of the custom axis. 

Move to In this field, you can enter an absolute target position, i.e. the position 
you want the custom axis to move to.  
This field is only available if the Absolute setting has been selected in the 
Moves are list box. 

Move In this field, you can enter a relative target position, i.e. the distance you 
want the custom axis to move by. 
This field is only available if the Relative setting has been selected in the 
Moves are list box. 

At speed These fields can be used to enter the speed [steps per second] at which 
you want the custom axis to move. 

mm 

Inches 

Units 

Steps 

The distances can be entered in millimeters, 
inches or motor steps. 

The mode for specifying the moves must be selected: 

Absolute The axis is moved to the position specified un-
der Move to. 

Moves are 

Relative The axis is moved by the value specified under 
Move. 

Go Clicking on this button performs the specified movement of the custom 
axis. 

HOME Clicking on this button rotates the custom axis to its home position. 

STOP Stops the movement of the custom axis. 
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8 USING PROFILES 
This chapter provides you with an overview of how to manage the profiles in weldMARK®.  
A profile is assigned to each marking object, which specifies the parameters for the laser 
marking. When you create a new object, the default profile is applied automatically. This pro-
file can be adapted to your individual requirements; however, changes only affect the objects 
that are created subsequently. 
If different laser settings are required (e.g. for marking different materials), any number of 
profiles can be created with different parameters. This is done using the Profile Manager. 
The Profile Manager lists all available profiles. The profiles can be organized and applied to 
marking objects. In addition, the parameters from a selected profile can be applied to the de-
fault profile. 
A profile can also be transferred from one marking object to another. 
The profiles included in the Profile Manager are available throughout the system, i.e. they are 
program-specific, not job-specific. 

8.1 Marking object profile 
The profile applied to the marking object determines the settings for laser processing, such as 
the power, frequency etc. These parameters are summarized on the Profile tab and can be 
changed as follows: 
o Right click on the marking object whose 

profile you want to change and then select 
Properties.... 

o Select the Profile tab. 
The adjacent window is opened.  
Refer to the table below for explanations. 
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Mark once The object is marked once. 

Mark multiple times The object is marked the number of times entered 
in the Passes field. 

2 pass Cut & Clean 

3 pass Cut & Clean 

Mode 

4 pass Cut & Clean 

The object is marked two, three or four times, and 
different laser parameters can be set for each pass. 
The settings can be called up using the passes that 
are available for selection in the Current Profile list 
box. 

Current Profile  If variable passes are selected in the Mode list box, this field can be used to 
call up the parameters for each individual pass. 

Passes  The Passes field is only available if Mark multiple times mode has been se-
lected. In this field, you can enter the required number of passes for the mark-
ing object. The object is marked this number of times during execution of the 
job even if it is only listed once in the object list. 

Use pens This field is only available if an imported object with layers is selected. 
In this case marking parameters can be defined for each pen after activating 
this function. The elements are displayed with the defined pen color. Elements 
on layers which are not selected for marking (tab CAD) are not shown. 

Laser power %  This field can be used to specify the laser power. The laser power can be en-
tered in percent (%) or watts depending on the settings in the laser configura-
tion file. 

Frequency This field can be used to set the frequency of the laser modulation signal. In 
association with YAG lasers, this is also referred to as the Q-Switch fre-
quency. 

Mark speed  This field can be used to specify the speed at which the laser beam moves 
over the object during processing. 

Pulse width  This field can be used to set the pulse width of the laser modulation signal. 
The maximum possible pulse width is determined by the frequency entered. 
This parameter is not available when using CO2 lasers. 

LaserOn delay  

LaserOff delay 

Mark delay 

Poly delay 

The adjacent parameters are described in detail in the application manual 
and/or in the "Commands and Functions" manual. 

Z position Via z-position the focal plane of the scan head can be adapted to the object to 
be marked. This field only is displayed if a 3-axis subsystem with 
FOCUSSHIFTER is set as scan head. The value for the z-position can be 
positive or negative. It is limited to the maximum values of the used 3-axis 
subsystem. 
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Jump speed 

Jump delay 

Var. jump length 

Var. jump delay 

Wobble frequency  

Wobble width  

The adjacent parameters are described in detail in the application manual 
and/or in the "Commands and Functions" manual. 

Zero power after 
mark 

If this function is activated, the laser power is set to zero after marking via 
Job>Run. 

Mark on  
dark material 

Only for bitmap objekts 
If this function is activated, the bitmap object will be marked inverted. This 
allows you to mark a pseudo-positive image on dark materials. 
In the weldMARK window the bitmap object is not displayed inverted. 

 

Hints for optimizing delay times  
The delay times must be adapted for the application and the jump and marking speeds en-
tered. Failure to optimize the delay times gives poor processing results and can increase the 
processing time. The length of the laser on and off delays have no influence on the process-
ing time. 
 
The procedure for setting the delay times is as follows: 
o Optimize the laser on and off delay.  

We recommend setting a high value for the jump and mark delays. 
o Optimize the delay times for controlling the galvanometer scanners, e. g. the jump, mark 

and poly delay.  
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8.2 Showing and hiding the Profile Manager 
o Select the View >Profile Manager option from the menu. 

The adjacent window is shown or hidden. 
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8.3 Creating and managing profiles  
In the Profile Manager, you can view, delete and modify existing object profiles and apply 
them to objects. You can also add new object profiles and organize all object profiles hierar-
chically. 

8.3.1 Creating profiles 
o Right click on the object whose profile 

you want to add to the Profile 
Manager. 

o Select the Add to Profiles... option 
from the menu. 
The adjacent window is opened.  
Refer to the table below for explana-
tions. 
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(1) If this function is enabled, the profile parameters for the selected object 
are applied to the default profile in the Profile Manager. 
The default profile is automatically applied to all new marking objects.  

Name The name of the profile is entered in this field. 

Create in << This window shows the Profile Manager folder structure. The new profile 
is saved in the selected folder. If no folder is selected, the profile is saved 
at the highest level in the Profile Manager structure. 

OK Clicking on this button saves the profile in the Profile Manager.  
 

 
Showing the Profile 

Manager 
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8.3.2 Organizing profiles 
You can structure individual profiles in folders or rename, move and delete them. 
o Select the Profiles >Organize Profiles... 

option from the menu, 
or 
Click on Organize in the Profile Manager.
The adjacent window is opened.  
Refer to the table below for explanations. 

o Click on Close to add the changed 
structure to the Profile Manager. 
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Create Folder Clicking on this button prompts the user to enter a folder name; a new 
profile folder is then created with the name entered. 

Rename Clicking on this button allows you to rename a selected folder or a profile. 

Move to Folder... Clicking on this button allows a selected profile to be moved to a different 
folder. 

Delete Clicking on this button deletes either a selected folder and the profiles it 
contains or a selected individual folder. 

8.4 Applying profiles 
The profiles saved in the Profile Manager can be applied to selected marking objects. The 
profile of one marking object can also be applied to other marking objects. 

8.4.1 Applying a profile from the Profile Manager to an object 
o Select the object to which you want to apply a profile. 
o In the Profile Manager, right click on the profile you want to 

apply. 
o Select the Apply to Object option from the menu. 
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8.4.2 Applying a profile from the Profile Manager to multiple objects 
o Select the objects to which you want to apply a profile. 
o In the Profile Manager, right click on the profile you want to 

apply. 
o Select the Apply to Group option from the menu. 
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8.4.3 Applying a profile from the Profile Manager to all objects 
o In the Profile Manager, right click on the profile you want to apply. 
o Select the Apply to All option from the menu. 

S067 
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8.4.4 Copying a profile from object to object 
o Right click on the object whose profile you want to 

copy. 
o Select the Copy Profile option from the menu. 
o Select the objects to which you want to copy the 

object. 
o Right click on the selected objects. 
o Select the Paste Profile option from the menu. 
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8.5 Modifying a saved profile  
o In the Profile Manager, right click on the 

profile for which you want to modify the 
parameters. 

o Select the Modify option from the menu. 
The adjacent window is opened. Explana-
tions can be found in the section below: 

 on page 108, Marking object profile. 
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8.6 The default profile 
The default profile is listed under the name Default in the Profile Manager. It cannot be de-
leted or moved to another folder. When you create a new marking object, the default profile is 
applied automatically. Markings performed to calibrate the marking field are performed using 
the settings in the test pattern profile. 
The default profile can be adapted to your individual requirements; however, changes only 
affect the objects that are created subsequently. 

8.6.1 Assigning the default profile the parameters for a marking object 
o Right click on the marking object 

whose profile parameters you want to 
applying to the default profile. 

o Select the Add to Profile Manager 
option from the menu. 
The adjacent window is opened. 

o Enable the check box (1). 
o Confirm the operation with OK. 
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8.6.2 Applying the parameters of a different profile to the default profile 
o In the Profile Manager, right click on the profile whose parameters you 

want to apply to the default profile. 
o Select the Copy to Default option from the menu. 

S071 

8.6.3 Modifying the default profile 
The default profile can be modified in the same way as any other profile (  on page 113, 
Modifying a saved profile). 
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8.7 Importing and exporting profiles 

8.7.1 Importing profiles 
Only profile folders can be imported, not individual profiles. The profile folder to be imported 
must be located in a folder with the name "Profiles". 
o Select the File > Import and Export 

Profiles... option from the menu. 
The adjacent window is opened. 

o Select Import Profiles from a folder and 
click on Next. 
The following window is opened. 
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o Click on Browse... and then select the 
folder named "Profiles", which contains the
profiles to be imported. 

o Select option (1) if you want to replace 
profiles with the same name or (2) if you 
do not want to do so. 

o Click on Next to perform the import. 
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8.7.2 Exporting profiles 
Only profile folders can be exported, not individual profiles. The profile folder to be exported is 
saved in a folder with the name "Profiles" (weldMARK® creates this folder if there is no folder 
with this name at the specified location). 
o Select the File > Import and Export 

Profiles... option from the menu. 
The adjacent window is opened. 

o Select Export profiles to a folder and click 
on Next. 
The following window is opened. 
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o Click on the Browse button. 
o Select the location in which you want to 

save the "Profiles" folder 
or 
Select the location of an existing "Profiles" 
folder in which you want to save the profile 
folder to be exported. 

o Click on the Next button. 
The following window is opened. 
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o Select the profile folder to be exported. 
o Click on Next to perform the export. 
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9 EXECUTING MARKING OBJECTS (QUICKMARK)  
This chapter provides an overview of the QuickMark function. The function enables you to 
execute the marking process with no automation objects or additional functions (e.g. serializa-
tion). It is also possible to mark only particular marking objects from a job. 
Before using the QuickMark function, you should familiarize yourself with the job settings 
(  on page 119, Job settings). 
  Warning:  

The laser beam can cause severe injury to the eyes and the skin. Make sure 
that there are no reflective objects in the beam path before starting the Quick-
Mark function and turning on the laser. Note that even apparently matt objects 
can reflect the wavelength of laser beams. 
All personnel in the room must wear appropriate laser protection goggles, or the 
marking area must be completely covered. Follow the local safety regulations, 
which can be obtained from the person responsible for laser safety. 

 
o Select the objects you want to mark. 

It you want to process all objects, 
you do not need to select an object. 

o Select the Job >QuickMark... option 
from the menu. 
The adjacent window is opened.  
Refer to the table below for explana-
tions. 
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Repeat Enabling this function means that once the marking process has been 
started it will be repeated until you stop it with the Stop button. 

All Executes all marking objects in the current job. 

Selected Executes only the selected marking objects. 

Stop Clicking on this button stops the marking process immediately. Alterna-
tively, you can do this by pressing the ESC key. 

(1) When laser marking is complete, the elapsed marking time is displayed in 
the status bar. 

 
QuickMark 
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PreviewMark 
The PreviewMark can be used if the laser system is fitted with a visible pointer and you have 
selected a laser driver file that supports a visible pointer in the system preferences. Note that 
the visible pointer needs to be calibrated in order for it to correctly represent the position of the 
marking laser (  on page 170, Calibrating the visible pointer).  
The Preview Mark shows the shape of a marking object or a group of marking object using the 
visible pointer. This shape can be used to position and scale the marking objects exactly.  The 
marking laser remains off. 
o Select the marking objects whose marking position 

and size you want to set. 
o Select the Job >PreviewMark... option from the 

menu. 
The adjacent window is opened.  
Refer to the table below for explanations. 
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Object position These buttons can be used to change the marking position of the se-
lected objects. 

Object size These buttons can be used to change the size of the selected objects. 

Settings Clicking on this button enables you to show or hide the slider for adjusting 
the speed of the visible pointer. 

Shape The object is shown as a rectangle, the shape of which symbolizes the 
object dimensions. 

Display speed This slider can be used to adjust the speed of the visible pointer. The 
higher the speed, the more static the representation of the shape. 

Apply Clicking on this button applies the settings made. 
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10 JOB SETTINGS, RUN JOB 
This chapter provides an overview of the sequence of a job, which settings you can make and 
how you run a job.  
When executing a job, all objects contained in the job are executed, including the automation 
objects and all additional functions for the objects, e.g. serialization. 

10.1 The Job Manager  
The Job Manager gives you an overview of the job settings. The settings can only be changed 
at the All editing functions access level. In Operator interface only mode, the Job Manager is 
read only, while it does not appear at all in Touchscreen interface mode. 

Showing and Hiding the Job Manager 
o Select the View >Job Manager option from the menu. 

The adjacent window is shown or hidden. 
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10.2 Editing the job settings 
The job settings enable you to adapt the execution of a job to specific requirements. The job 
settings are saved as part of the job itself. The job settings are divided up as follows: 

Page Setup Allows you to set the format and size of the 
workspace. 

 on page 120, Job settings - 
"Page Setup" 

Repeat Process Execution of the job can be repeated several 
times or continuously. 

 on page 121, Job Settings 
„Repeat Process“ 

Step & Repeat The matrix function allows an object to be 
marked several times. The duplication is 
based on adjustable row and column ar-
rangements. 

 on page 122, Job settings - 
"Step & Repeat" 

Job Initialize  When running the job, external components 
can be automatically prepared for the marking 
process. 

 on page 123, Job Settings 
„Job Initialize“ 

External Start The start of job execution can be controlled by 
external signals. 

 on page 124, Job settings - 
“External Start” 

Notes A note can be added to the job.  on page 125, Job settings - 
"Notes" 

Interlocks Execution of the job can be interrupted by 
external interlock loops. 

 on page 126, Job settings - 
"Interlocks" 

 

 
Job Manager 



Chapter 10 Job settings, Run job 

120 RAYLASE weldMARK® MN013 / v2.0 

10.2.1 Job settings - "Page Setup" 
o Select the Job >Settings... option.

or 
Double click on the Page Setup 
option in the Job Manager. 
The adjacent window is opened.  
Refer to the table below for expla-
nations. 
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Format You can select a rectangular or circular workspace. 

Width 

Height 

The size of the workspace can be adjusted. The maximum size of the 
workspace is determined by the size of the deflection unit's operating 
field. 

Apply Hardware defaults Clicking on this button sets the workspace to its maximum possible size 
(size of deflection unit's operating field). 

Save Settings as Default Clicking on this button allows you to save the current settings as the de-
faults for the PageSetup. 
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10.2.2 Job Settings „Repeat Process“  
o Select the Job >Settings... option. 
o Select the Repeat Process tab. 

The adjacent window is opened.  
Refer to the table below for expla-
nations. 
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If you select a manual repeat function, each new execution of the job 
must be started manually. 

(1) The job is executed as many times as you wish. 

FOR OPERATION 
FROM THE CONSOLE 

(2) The frequency of execution is limited by the specified number of 
Cycles. 

It you select an automatic repeat function, execution of the job is auto-
matically restarted after completion of a cycle. 

(3) Execution of the job is automatically repeated continuously. 

AUTOMATION ONLY 

(4) Execution of the job is automatically repeated for the specified 
number of Cycles.  

(5) Only selectable if  a SP-ICE Control Card is used 

If this function is enabled, the settings are also used in Run from Hard-
ware mode. 
This option is only available if Run from Hardware mode is enabled 
(  on page 129, Run from Hardware). 

Save Settings as Default Clicking on this button uses the current settings as the defaults for Re-
peat Process. 
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10.2.3 Job settings - "Step & Repeat"  
The Step & Repeat function allows objects to be marked several times. The duplication is 
based on adjustable row and column arrangements. 
o Select the Job >Preferences option 

from the menu. 
o Select the Step & Repeat tab. 

The adjacent window is opened.  
Refer to the table below for expla-
nations. 
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If this function is enabled, the following parameters can be set: 

Layout If a standard I/O card is installed, up to four 
matrix layouts can be created. Each layout 
can have a different matrix arrangement. The 
layout can be selected using the ports on the 
standard I/O card. 

Count Columns  

Pitch 

Count Rows 

Pitch 

The matrix is made up of columns and rows. 
You can specify the number of rows and col-
umns and the distance between them (pitch). 

X axis Pattern offset 

Y axis 

The position of the matrix on the marker can 
be adjusted using these offset values. 

Preview Clicking on this button updates the preview 
window. 

Reset All Clicking on this button restores all settings to 
the defaults. 

Use Step & Re-
peat 

Save Settings as Default Clicking on this button uses the current set-
tings as the defaults for Step & Repeat. 
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10.2.4 Job Settings „Job Initialize“  
When the job is started, the RS232 port can be used to output a string to initialize external 
components. In addition, you can specify a port to be used to report execution of the job to 
external components. As initialization is job specific, the components can be initialized in a 
different way for each job that is loaded. 
o Select the Job >Settings... option. 
o Select the Job Initialize tab. 

The adjacent window is opened.  
Refer to the table below for expla-
nations. 
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Don't send a script No script is sent to initialize external components. 

A script is sent to initialize external components using an RS232 port. 

I/O Port Select an RS232 port for sending the script. 

Data Bits 

Stop Bits 

Baud Rate 

Parity 

These parameters are used to adapt the RS232 port to 
the parameters of the script recipient. 

Script file 

Send script using RS-232 
COM port 

Browse... 

Select the script file to be sent using the RS232 port. 

I/O card action 

Use I/O port 

A port can be selected. The port must be assigned an action that is to 
be executed when the job is started. 

Save Settings as Default Clicking on this button uses the current settings as the defaults for Ini-
tialization. 
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10.2.5 Job settings - “External Start” 
The External Start function allows execution of the job to be controlled by an external signal. 
This tab is only available if the standard I/O card is installed and/or SP-ICE/RLC series control 
cards are installed.  

Select the Job >Settings option 
from the menu. 
Select the External Start tab. 
The adjacent window is opened.  
Refer to the table below for expla-
nations. 
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(1) If this check box is selected, the External Start function is deactivated. 

If this check box is selected, the External Start function is activated and the following setting 
options are available: 

Use I/O port This selection box can be used to choose the port for the start signal. 
The selection options vary depending on the cards installed. 

Message A text can be entered for a message that appears during the waiting 
time. 

Timeout A time limit can be placed on the waiting time for the external start signal. 
When this time has elapsed, an error message will be output. If a value 
of "0" is entered, the waiting time is unlimited. 

(3) The job is not started until the start signal is de-asserted. 

(4) The job is started as soon as the start signal is asserted. 

(5) If this function is enabled, the selected parameters are also used in Run 
from Hardware mode. 
This option is only available if Run from Hardware mode is enabled 
(  on page 129, Run from Hardware). 

(2) 

Save Settings 
as Default 

Clicking on this button uses the current settings as the defaults for Exter-
nal Start. 
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10.2.6 Job settings - "Notes"  
A note can be added to the job. weldMARK® can be set up in such a way that the job note is 
automatically displayed when loading a job and has to be acknowledged by the user (  on 
page 150, Settings for the job file). 
o Select the Job >Settings option 

from the menu. 
o Select the Notes tab. 

The adjacent window is opened.  
Refer to the table below for expla-
nations. 
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Save Settings as Default Clicking on this button uses the text entered as the default for Notes. 
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10.2.7 Job settings - "Interlocks"  
Use the settings on the Interlocks tab to set when and how weldMARK® will report interlock 
events. The Interlocks tab is only available if an interlock card is installed. 
o Select theJob >Settings option 

and then select the Interlocks 
tab. 
The adjacent window is 
opened.  
Refer to the table below for ex-
planations. 

 

 

(1) If this check box is enabled, the interlock status is checked before start-
ing each job. If there is an interlock event, the job is not started and an 
error message is output. 

(2) If this check box is enabled, the interlock status is checked while the sys-
tem is waiting for the external start signal and, if necessary, an error 
message is output. If the check box is not enabled, an interlock event 
does not result in an error message but the start signal is ignored and 
the READY signal on the standard I/O card changes to BUSY. 

(3) Clicking on this button uses the current settings as the defaults for Inter-
locks. 

 

1
2

3
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10.3 Executing a job 
In order to be able to execute a job, the Object Manager must contain at least one object that 
can be marked. The procedure for starting a job differs depending on the access level and is 
described below. 
 
  Warning:  

The laser beam can cause severe injury to the eyes and the skin. Make sure 
that there are no reflective objects in the beam path before starting a job and 
turning on the laser. Note that even apparently matt objects can reflect the 
wavelength of laser beams. All personnel in the room must wear appropriate 
laser protection goggles, or the marking area must be completely covered. Fol-
low the local safety regulations, which can be obtained from the person respon-
sible for laser safety. 

 

Starting a job at "All editing functions" access level 
o If necessary, open the required job. 
o Select the Job >Run option from the menu.

The adjacent window is opened. 
o Click on the Go button. 

The job is executed. 

Stopping the job 
Click on the Stop button or press the ESC 
key. 
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Starting a job at "Operator interface only" access level 
o If necessary, open the required job. 
o Select the Job >Run option from the menu. 

The adjacent window is opened. 
o Click on the Go button. 

The job is executed. 

Stopping the job 
o Click on the Stop button or press the ESC 

key. 
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Starting a job at "Touch screen interface" access level 
o If necessary, open the required job. 
o Touch the Run button. 

The job is executed. 

Stopping the job 
o Touch the Stop button or press the ESC key. 

 
Run Process 
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10.3.1 Displays during a job 
While the job is being executed, the following values are displayed in the status bar: 

Cycle count  How often the entire Object Manager has been executed so far. 

Object count  Number of objects processed so far. 

Cycle time Time required to execute the current job (current cycle). 

Current object  The object that is currently being processed. 

10.3.2 Events during a job  
Depending on the objects included in the job and their properties, the program may prompt 
the user for input during execution. 

Entering a string 
If an object has been created for which a string is to be 
entered by the user, the adjacent window is opened.  
Refer to the table below for explanations. 
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(1) 

OK 

Input box for the string to be used for marking the object. Execution of 
the job is continued as soon as the entry is confirmed by clicking on the 
OK button. 

Skip Clicking on this button skips the input prompt. The object is marked using 
the last string used. 

 

Parameters for TextMerge 
If an object has been created that uses a 
TextMerge function, the adjacent window is 
opened. Refer to the table below for explana-
tions. 
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The beginning of the file The first string for the object is taken from the first line of the merge file. 

At line number The first string for the object is taken from the specified line of the merge 
file. The available line numbers are specified in brackets. 

The previous bookmark 
location 

The first string is taken from the line in the merge file that is bookmarked. 
This option is not available until at least one line has been read from the 
merge file. 
The bookmark is inserted each time a line from the merge file is read and 
specifies the next line to be read. This allows serialization to continue 
seamlessly after restarting the job. 
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10.3.3  Run from Hardware  
weldMARK® allows all marking objects in a job to be loaded to the control card memory. This 
enables the job to be executed very quickly as possible delays caused by the operating sys-
tem are avoided. However, no automation objects can be executed. 
To allow direct operation, the following conditions must be met: 
 A SP-ICE control card must be used. 
 The Run from Hardware mode must be activated. 
 The job may not contain more objects than can be stored in the available memory on the 

control card. 
 

Activating "Run from Hardware" mode 
o System >Preferences option from 

the menu. 
o Select the Hardware tab. 

The adjacent window is opened. 
o Select the control card for which 

you want to activate the mode. 
o Click on the Configure button. 

The following window is opened. 
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o Select the Display tab. 
o Enable the Display Run from 

Hardware menu items and controls 
check box. 
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Running a Job from Hardware  
 
  Warning:  

The laser beam can cause severe injury to the eyes and the skin. Make sure 
that there are no reflective objects in the beam path before starting a job and 
turning on the laser. Note that even apparently matt objects can reflect the 
wavelength of laser beams. All personnel in the room must wear appropriate 
laser protection goggles, or the marking area must be completely covered. Fol-
low the local safety regulations, which can be obtained from the person respon-
sible for laser safety. 

 
o Select the Job >Run from Hardware option 

from the menu. 
The adjacent window is opened.  
Refer to the table below for explanations. 

S191

 

Clicking on this button sends the marking objects to the control card. Download 

Go This button only becomes active when all marking objects have 
been saved on the control card. Clicking on the button starts execu-
tion of the job. 

 (1) If this function is enabled, the job is not executed until the hardware 
signal is present. 

 (2) If this function is enabled, the job is executed repeatedly (  on page 
121, Job Settings „Repeat Process“”). 

 Stop Clicking on this button or pressing the ESC key stops execution im-
mediately. 
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10.3.4  Stand Alone Operation 
weldMARK® allows all objects in a job to be loaded to the memory on a stand alone control 
card. The job can then be executed from the control card itself without a connection to weld-
MARK®. This function is only available with SP-ICE control cards. 
In order to be able to save a job on a stand alone control card, the following conditions must 
be met: 
 The corresponding hardware must be available. 
 The function must be enabled. 
 The job may not contain more objects than can be stored in the available memory on the 

control card. 
 

Enabling "Save to stand alone control card" mode 
o Select the System >Preferences 

option from the menu. 
o Select the Hardware tab. 
o Select the control card for which 

you want to activate the mode. 
o Click on the Configure button. 

The adjacent window is opened. 
o Select the Display tab. 
o Enable the Display Embedded 

Controller menu items and controls 
check box. 
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Saving a job to a stand alone control card 
o Select the File >Save Job to Embedded 

Controller option from the menu. 
The adjacent window is opened. 

o Select a script file from the list. 
o Click on the Send button to start 

saving.  
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10.4 The "Mark on the Fly" option  
The Mark on the Fly option allows moving workspaces to be marked. This requires an SP-ICE 
control card with an MOTF add-on card. The add-on card is connected to an encoder that 
detects the current speed of the marker; the vectors for a job are then adjusted according to 
the speed.  
In order to be able to use the Mark on the Fly option, the following conditions must be met: 
 The corresponding hardware (SP-ICE control card with MOTF add-on card) and a suitable 

encoder signal must be available. 
 The function must be enabled. 

 

Activating the "Mark on the Fly" option   
o Select the System >Preferences 

option from the menu. 
o Select the Hardware tab. 
o Select the card for which you want 

to activate the mode. 
o Click on the Configure button. 
o Select the Mark on the Fly tab. 

The adjacent window is opened.  
Refer to the table below for expla-
nations. 
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If this function is enabled, the following settings are available: 

Scale factor This field can be used to enter the number of pulses emitted 
by the encoder for each millimeter of movement of the 
marker (this is the same for each other set measuring unit). 

Orientation Rough setting for the direction of 
movement of the marker. "0" 
corresponds to a horizontal 
movement from left to right. The 
orientation entered under Sys-
tem >Preferences... on the 
Marker tab is not taken into ac-
count. Rotation is clockwise. 

Enable Mark on 
the Fly 

Angle Precise setting for the direction 
of movement of the marker. You 
can enter an angle between -45° 
and +45°. 
Rotation is clockwise, relative to 
the X-axis configured under Sys-
tem >Preferences... on the 
Marker tab. 

If the marker is moving 
at a 20° angle relative to 
the X-axis, enter "0" in 
the Orientation field and 
"20" in the Angle field. 
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10.5 Master/slave mode 
In a PC one SP-ICE control card can be defined as master card and up to three cards as 
slave cards. 
In master/slave operation weldMARK® sends the job file to the master SP-ICE control card. 
This master card controls the connected scan head and the laser – like in normal operation 
with a SP-ICE control card. Additionally, the master card controls the slave SP-ICE control 
cards. Thus the content of a job file can send to up to four SP-ICE control cards (one master 
and three slave cards) which allows to control up to four scan heads. 
Information in detail can be found in the hardware manual of the SP-ICE control card. 

Activating option „Master-Slave“  
o Select the System >Preferences 

option from the menu. 
o Select the Hardware tab. 
o Select the card for which you want 

to activate the mode. 
o Click on the Configure button. 
o Select the Master-Slave tab. 

The adjacent window is opened.  
Refer to the table below for 
explanations. 
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Scan Head 1 (Master) Via this check box SP-ICE control card „1“ can be 
defined as master. 

Scan Head 2 

Scan Head 3 

Scan Head 4 

Via these check boxes each other built-in SP-ICE 
control card can be activated for slave operation. 
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10.6 Printing a job 
The content of the workspace can be printed as described below: 
o Select the File >Print Setup... option and 

make the required settings (printer, paper 
size, orientation).  

o Select the File > Print option from the menu. 
The adjacent window is opened.  
Refer to the table below for explanations. 
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As in job (1:1) The objects are printed at actual size. 

Fit to page The printout is scaled to use the full size of the page. 

The printout is scaled as specified and centered on the page. 

Width  

Height  

The width and height of the printout can be 
changed as a percentage of the actual size. 

Center image on page 

Maintain aspect 
ratio  

If this function is enabled, the aspect ratio of the 
printout remains unchanged even if the print size is 
changed (no distortion). 

Show field size boundary If this function is enabled, the boundaries of the workspace are printed 
as a frame. 

The Setup or Print but-
tons 

Clicking on these buttons calls up the printer settings. 
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11 SYSTEM TOOLS  
weldMARK® provides the following system tools: 

Configure Tools The tool menu can be extended 
with options for calling up external 
programs. 

 below, Configure Tools 

Configure I/O Cards... This tool allows you to configure 
newly installed I/O cards. 

 on page 137, Configure I/O 
Cards 

Laser Diagnostics Tool This tool allows you to check the 
positioning and power of the mark-
ing laser. 

 on page 138, Laser Diagnostics 
tool 

I/O Card diagnostics   on page 139, "I/O Card Diag-
nostics" tool 

 

11.1 Configure Tools  
The weldMARK® Tools menu can be extended with additional tools (external programs). 
These programs can then be launched from within weldMARK®. 
o Select the Tools >Configure Tools... option from the 

menu. 
The adjacent window is opened.  
Refer to the table below for explanations. 
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Tools This section of the window lists all programs added. 

Add Clicking on this button allows new tools to be added to the Tools list 
(  on page 136, Adding / editing tools). 

Delete Clicking on this button removes the selected tool from the list. 

Edit Clicking on this button allows you to edit the settings for the tool selected 
in the Tools list (  on page 136, Adding / editing tools). 

  
These buttons can be used to change the position of a program in the list 
(and also in the Tools menu). 
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Adding / editing tools 
o Select the Tools >Configure Tools... option 

from the menu. 
o Click on the Add button. 

The adjacent window is opened.  
Refer to the table below for explanations. 
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Title The name of the selected program file is automatically entered in this 
field when the Browse button has been used to select a program. This 
name can be changed as required. The entry in the Title field is used in 
the Tools menu. 

Program The location of the selected program file is automatically entered in this 
field when the Browse button has been used to select a program. The 
path to the selected program can also be entered manually. 

Parameters This field can be used to enter parameters for calling up the program. 
Refer to the manual for the relevant program for details of which parame-
ters are available. 
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11.2 Configure I/O Cards 
If a new standard I/O card and/or interlock I/O card (type CIO-DIO24H card) has been in-
stalled in the computer, it must be configured using the Configure I/O Cards... tool.  
Configuration must be performed again if a PCI card is removed, added or moved within the 
computer. 
 
 

 
 

Warning:  
This tool is only necessary when using I/O cards with a PCI slot. Do NOT use this 
tool for ISA I/O cards, otherwise the communication with the ISA card may be lost. 

 
o Select the Tools >Configure I/O 

Cards... option from the menu. 
A warning message relating to ISA I/O 
cards appears. 

o Read and acknowledge the warning 
message. 
The Instacal program is opened in the 
adjacent window. 
All installed I/O cards are displayed in 
the list. The cards are now set up for 
use with weldMARK®. 

o Exit Instacal by selecting File >Exit. 
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11.3 Laser Diagnostics tool 
The Laser Diagnostics tool can be used to diagnose and, if necessary, adjust the impact point 
and power of the marking laser you are using. 
  Warning:  

The laser beam can cause severe injury to the eyes and the skin. Make sure 
that there are no reflective objects in the beam path before starting a job and 
turning on the laser. Note that even apparently matt objects can reflect the 
wavelength of laser beams. All personnel in the room must wear appropriate 
laser protection goggles, or the marking area must be completely covered. Fol-
low the local safety regulations, which can be obtained from the person respon-
sible for laser safety. 

 
o Select the Tools >Laser Diagnostics... 

option from the menu. 
The adjacent window is opened.  
Refer to the table below for explanations. 
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X: 

Y: 

The values in these input boxes determine the position to which the laser 
beam is directed after clicking on the Fire button. 

Laser power This input box determines the laser power. 

Frequency This input box determines the frequency of the laser modulation signal. 

Pulse width This input box determines the pulse width of the laser modulation signal. 

Fire Clicking on this button turns on the laser immediately. 

Stop Clicking on this button turns off the laser immediately. 

Done Clicking on this button closes the Laser Diagnostics tool. 
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11.4 "I/O Card Diagnostics" tool 
This tool allows the ports for the standard I/O card and the interlock I/O card (type: CIO-
DIO24H card) to be tested. The tool is only available if one of these cards is installed. 

Reading inputs from the standard I/O card 
The following function is only available if a standard I/O card is installed: 
 

o Select the Tools >I/O Card Diagnostics... 
option from the menu.  
A warning message appears. 

o Read and acknowledge the warning 
message. 

o Under Standard I/O Card select the Inputs
option. 
The adjacent window is opened.  
Refer to the table below for explanations. 
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Function This column lists the names used for the input ports in weldMARK®.  

Pin # This column lists the PIN numbers on the 37-pin connector on the I/O 
card. 

Status This column specifies the current status of the input ports. If the status is 
TRUE, the corresponding port is connected to GND. 

 



Chapter 11 System tools 

140 RAYLASE weldMARK® MN013 / v2.0 

Testing outputs on the standard I/O card 
The following function is only available if a standard I/O card is installed: 
 

o Select the Tools >I/O Card Diagnostics... 
option from the menu.  
A warning message appears. 

o Read and acknowledge the warning 
message. 

o Under Standard I/O Card select the 
Outputs option. 
The adjacent window is opened. 
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Function This column lists the names used for the output ports in weldMARK®. 

Pin # This column lists the PIN numbers on the 37-pin connector on the I/O 
card. 

FALSE 

TRUE 

Clicking on these buttons allows you to switch the corresponding output 
to the status FALSE or TRUE for testing purposes. If the status is TRUE, 
the corresponding input is connected to GND. 
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Reading inputs from the interlock I/O card 
The following function is only available if an interlock I/O card is installed: 
 

o Select the Tools >I/O Card Diagnostics... 
option from the menu.  
A warning message is displayed. 

o Read and acknowledge the warning 
message. 

o Under Interlock Card , select the Inputs 
option. 
The adjacent window is opened. 
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Function This column lists the names used for the input ports in weldMARK®. 

Pin # This column lists the PIN numbers on the 37-pin connector on the I/O 
card. 

Status This column specifies the current status of the ports. Each interlock port 
can have the status HIGH or LOW. If the status is LOW, the correspond-
ing input is connected to GND. 
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12 SYSTEM SETTINGS 
This chapter provides an overview of the configuration of the weldMARK® environment: 

Preferences The settings for the weldMARK® user interface 
can be changed throughout the system. 

 below, Preferences 

Properties... The current system properties for Windows 
and all of the configured hardware can be 
changed. 

 on page 154, System 
properties displays 

Globals... The laser power, the marking speed and the 
position of the marking objects can be 
changed throughout the system. 

 on page 155, Global 

Security  Access to weldMARK® can be controlled using 
access rights and passwords. 

 on page 156, System 
security settings 

Backup.../ 
Restore...  

All system settings used by weldMARK® can 
be saved in a backup file and loaded from a 
backup file. 

 on page 157, Backing up 
system settings 

12.1 Preferences 
The weldMARK® system preferences are divided into groups and split across several tabs: 

Marker  on page 143, Settings for marking field 

Workspace  on page 143, Workspace settings 

Hardware weldMARK® can be adapted for various 
deflection units, control cards and laser 
systems.  

 on page 144, Hardware Configu-
ration (without control card) 

 on page 146, Hardware configu-
ration (with control card) 

Job Files  Job files can be automatically saved and 
loaded. In addition, you can also specify a 
folder in which jobs are saved to be loaded 
when using the Operator interface only and 
Touchscreen interface access levels. 

 on page 150, Settings for the job 
file 

Host Interface  weldMARK® can communicate with external 
programs using different protocols and pa-
rameters. 

 on page 151, Editing the host 
interface settings 

Languages  The weldMARK® user interface can be set 
to one of the supported languages. 

 on page 151, Language settings 

LaserSaver After a certain time has elapsed, the laser 
can be automatically blocked and/or the 
laser power reduced. 

 on page 152, Setting the Laser-
Saver 

Beam Home The scanner mirrors in the deflection unit 
can automatically be moved to a particular 
position at the end of a processing se-
quence. 

 on page 153, Setting up the 
beam home position 

Motor control The parameters for an installed motor con-
trol card can be adjusted. 

 on page 175, Operating stepper 
motors 
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12.1.1 Settings for marking field 
o Select the System >Preferences 

option from the menu. 
o Select the Marker tab. 

The adjacent window is opened.  
Refer to the table below for explana-
tions. 
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(1) If this function is enabled, a warning is displayed on the screen if one of the objects is 
located outside the marking field. 

(2) If this function is enabled, the laser power settings specified in the object profiles are ig-
nored. The laser power can then be adjusted externally. 
This function can only be enabled if it has been released when installing the laser driver 
(  on page 166, Configuring a laser driver). 

Scan 
Rotation 

Note the orientation of the marking field, which is represented in the figure next to the 
check boxes. 

12.1.2 Workspace settings 
o Select the System >Preferences 

option from the menu. 
o Select the Workspace tab. 

The adjacent window is opened.  
Refer to the table below for explana-
tions. 
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Interface display units  Selection box for the unit for the ruler display and for the input dialogs. 

Keyboard nudge  This field determines how far an object is moved when it is nudged using 
the arrow keys (arrow + CTRL key). 

Start a new job on appli-
cation startup 

If this function is enabled, a new job is automatically opened when 
weldMARK® is started. 
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12.1.3 Hardware Configuration (without control card)  
If weldMARK® does not find a control card when it is started for the first time, the defaults for 
the correction file and for the laser driver are automatically activated. If you want to create 
jobs without connecting hardware, however, it is necessary to adjust the correction file for the 
deflection unit and the laser that you will use later. This means that weldMARK® will set the 
correct workspace size and release all options for the selected laser.  
o Select the System >Preferences 

option from the menu. 
o Select the Hardware tab. 

The adjacent window is opened.  
Refer to the table below for explana-
tions. 
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Default lens, Change...  below, Select default correction file 

Default laser, Change...  on page 145, Select default laser driver 
 

Select default correction file 
This section describes how to select a correction file if no control card is installed. 
o Select the System >Preferences option 

from the menu. 
o Select the Hardware tab. 
o Click on the Change... button to the right of 

the Default lens list box. 
A warning message appears. 

o Read and acknowledge the warning 
message. 
The adjacent window is opened.  
Refer to the table below for explanations. 

S120

 

Correction File  This text box displays the currently selected correction file. 

Available Correction 
Files 

This list box displays all available correction files. 

Install New File... Clicking on this button starts the wizard for installing a correction file that 
is not included in the list. 
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Select default laser driver 
This section describes how to select a laser driver if no control card is connected. 
o Select the System >Preferences option 

from the menu. 
o Select the Hardware tab. 
o Click on the Change... button to the right of 

the Default laser list box. 
A warning message appears. 

o Read and acknowledge the warning 
message. 
The adjacent window is opened.  
Refer to the table below for explanations. 
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Laser Driver This text box displays the currently selected laser driver file. 

Available Laser Drivers This list box displays all available laser drivers. 

Install New Laser... Clicking on this button starts the wizard for installing a laser driver file 
that is not included in the list. 
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12.1.4 Hardware configuration (with control card)  
If a control card is installed, the currently set laser driver file and the correction file for the de-
flection unit can be viewed and, if necessary, changed as follows: 
o Select the System >Preferences 

option from the menu. 
o Select the Hardware tab. 

The adjacent window is opened. 
o Select the driver you want to change 

from the list. 
Refer to the table below for explana-
tions. 
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(1) Control Card  Configure...  on page 147, Configure control card 

Configure...  on page 166, Configuring a laser driver (2) Laser Driver 

Change...  on page 150, Select laser driver 

Configure… Selectable only with a connected Dongle and after 
selecting a suitable scan head. 

 on page 148, Configure 3-axis subsystem 

(3) 
 

Scan Head 

Change  on page 147, Select/change type of Scan Head 

Calibrate...  on page 158, Calibrating the marking field (4) Correction File  

Change...  on page 144, Select default correction file 
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Configure control card 
Only valid for SP-ICE control cards 

o Select the System >Preferences 
option from the menu. 

o Select the Hardware tab. 
o Click on the required control card in 

the hardware list. 
o Click on the button Configure. 
o Select the Display tab. 

The adjacent window is opened.  
Refer to the table below for expla-
nations. 
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Display Run from Hardware 
menu items and controls 

If this function is enabled, marking objects can be completely saved 
on the control card first and then executed directly from the card. 

Display Embedded Control-
ler menu items and controls 

If this function is enabled, marking objects can be completely saved 
on a control card first and then executed directly from the card without 
a PC connection. 

Mark on the Fly  on page 132, The "Mark on the Fly" option 

Master-Slave  on page 133, Master/slave mode 
 

Select/change type of Scan Head 
o Select System >Preferences option from 

the menu. 
o Select Hardware tab. 
o In the hardware list select the desired scan 

head. 
o Click on button Change…. 
o Read and confirm the following warning 

message. The adjacent window is opened. 
Refer to the table below for explanations. 
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Scan Head Shows the actually selected scan head. 

Available Scan Head Con-
figuration files 

Selection list of all scan heads for which configuration files are in-
stalled. 

OK To confirm the selection and to return to the hardware configuration 
 on page 146, Hardware configuration (with control card) 



Chapter 12 System settings 

148 RAYLASE weldMARK® MN013 / v2.0 

Select correction file 
This section describes how to select a correction file if a control card is connected. 
o Select the System >Preferences option 

from the menu. 
o Select the Hardware tab. 
o In the hardware list, click on the correction 

file displayed under the deflection unit you 
are using. 

o Click on the Change button. 
o Read and acknowledge the confirmation 

prompt that appears. 
The adjacent window is opened.  
Refer to the table below for explanations. 
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Correction File  This text box displays the currently selected correction file. 

Available Correction 
Files 

This list box displays all available correction files. 

Install New File... Clicking on this button starts the wizard for installing a correction file that 
is not included in the list. 

 

Configure 3-axis subsystem 
Only valid for 3-axis subsystems with motorised linear translator 

o Select System >Preferences option 
from the menu. 

o Select Hardware tab. 
o In the hardware list select the 

desired scan head. 
o Click on button Configure. 

The adjacent window is opened.  
Refer to the table below for 
explanations. 
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Enable automatic LT  
Adjustment 

Enables the control of the linear translator. 

Use Motor Controller Allows selecting the motor controller. 

Axis Allows the mapping of the motor axis. 
For the linear translator axis 3 is selected as default.  

Adjust LT position  on page 149, Positioning of linear translator. 
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Positioning of linear translator 
Only valid for scan heads with motorised linear translator 

The 3-axis subsystem has to be focused to the working plane. In case the working plane field 
size has been changed, the 3-axis subsystem has to be focused again by moving the linear 
translator to the new working position.  
Via weldMARK a test pattern can be issued to the scan head. The marking result allows a 
judgement and optimization of the focusing. 
  Warning:  

The laser beam can cause severe injury to the eyes and the skin. Make sure 
that there are no reflective objects in the beam path before marking the test 
pattern and therefore turning on the laser. Note that even apparently matt ob-
jects can reflect the wavelength of laser beams. All personnel in the room must 
wear appropriate laser protection goggles, or the marking area must be com-
pletely covered. Follow the local safety regulations, which can be obtained from 
the person responsible for laser safety. 

 
o Select System >Preferences option from the 

menu. 
o Select Hardware tab. 
o In the hardware list select the desired scan head.
o Click on button Configure  
o Click on button Adjust LT position. 

The adjacent window is opened.  
Refer to the table below for explanations. 
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Preset Displays the linear translator’s home postion. 

Offset Displays the stored working position of the linear translator. 
The value is relative to the home position. 

Physical Displays the absolute position of the linear translator. 

Current Displays the actual position of the linear translator relative to the zero 
position. 

Move To To enter a nominal value for the position of the linear translator. 

Mark Test Pattern To issue a test pattern for judgement of the focusing quality. 

Preset to Saved The value of Move To is reset to the last saved value for position of 
the linear translator. 

STOP To stop the movement of the linear translator. 

Move To move the linear translator to the position defined in field Move To. 

Save To store the actual position of the linear translator. 

Save and Exit To store the actual position of the linear translator and exit the ad-
justment window. 
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Select laser driver 
This section describes how to select a laser driver if a control card is connected. 
o Select the System >Preferences option 

from the menu. 
o Select the Hardware tab. 
o In the hardware list, click on the laser driver 

file you want to change. 
o Click on the Change button. 
o Read and acknowledge the confirmation 

prompt that appears. 
The adjacent window is opened.  
Refer to the table below for explanations. 
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Laser Driver  This text box displays the currently selected laser driver file. 

Available Laser Drivers This list box displays all available laser driver files. 

Install New Laser... Clicking on this button starts the wizard for installing a laser driver file 
that is not included in the list. 

 

12.1.5 Settings for the job file 
The settings for job files are shown in the window below.  
o Select the System >Preferences 

option from the menu. 
o Select theJob Files tab. 

The adjacent window is opened.  
Refer to the table below for explana-
tions. 
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(1) If this function is enabled, a backup file (with the extension .bak) is automatically created when 
saving a job file. The function is enabled by default. 
The backup file is saved in the specified folder. Clicking on the Browse... button allows you to 
select a different folder. 

(2) If this function is enabled, the job file specified in the text box will be opened automatically 
each time you start weldMARK®. Clicking on the Browse button allows you to select a different 
job file. 

(3) If this function is enabled, the designated job file will be executed each time you start  
weldMARK®. 

(4) This field specifies the location for jobs that can be loaded when working in the access levels 
Operator interface only and Touchscreen interface. 

(5) If this function is enabled, any job notes will be displayed automatically when a job is loaded 
(  on page 125, Job settings - "Notes"). 

(6) If this function is enabled, the job will be saved during running, if it is changed during process-
ing (serialization). 
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12.1.6 Editing the host interface settings 
The host interface provides an interface that external programs can use to communicate with 
weldMARK®. 
o Select the System >Preferences 

option from the menu. 
o Select the Host Interface tab. 

The adjacent window is opened. 
For further information on the set-
tings, refer to the RAYLASE Remote 
Interface Manual, which you will re-
ceive separately. 
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12.1.7 Language settings 
weldMARK® supports various languages for the user interface. After installation, English 
(United States) is set as the default language. 
o Select the System >Preferences 

option from the menu. 
o Select the Languages tab. 

The adjacent window is opened.  
Refer to the table below for explana-
tions. 
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Available languages This list box shows all available languages. 
When you change the language, you must first click on the Set as De-
fault button and then restart weldMARK®. The user interface will then be 
available in the selected language. 

Set as Default Clicking on this button sets the language selected from the list box as the 
default language. 
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12.1.8 Setting the LaserSaver 
After a certain time has elapsed, the laser can be automatically blocked and/or the laser 
power reduced. An optional error message can also be set. 
Note: The LaserSaver is primarily intended for Nd:YAG lasers. 
 
o Select the System >Preferences 

option from the menu. 
o Select the LaserSaver tab. 

The adjacent window is opened.  
Refer to the table below for explana-
tions. 
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If this function is enabled, the time controlled LaserSaver is activated; options (2) to (4) are 
then available. 

(2) If this function is enabled, when the time entered has elapsed the interface that con-
trols the laser power is adjusted to its minimum settings. 

(3) If this function is enabled, when the time entered has elapsed a corresponding script is 
sent to the laser via the RS233 port. Further information on this function is available 
from the manufacturer. 

(1) 

(4) If this function is enabled, when the time entered has elapsed the error port on the 
standard I/O card is set. 



System settings Chapter 12 

MN013 / v2.0 RAYLASE weldMARK® 153 

12.1.9 Setting up the beam home position  
The scanner mirrors in the deflection unit can automatically be moved to a particular position 
at the end of a processing sequence. If this function is disabled, the mirrors remain at the end 
position of the last object to be marked. 
o Select the System >Preferences 

option from the menu. 
o Select the Beam Home tab. 

The adjacent window is opened.  
Refer to the table below for explana-
tions. 
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(1) If this function is enabled, the beam moves to the home position entered 
at the end of a job initiated using the Job >Run command in the menu. 

(2) If this function is enabled, the beam moves to the home position entered 
at the end of a job initiated using the Job > QuickMark command in the 
menu. 

Home to These input boxes are used to 
define the home position. 

Home speed This input box is used to specify 
the speed with which the beam 
moves to the home position. 

The unit used can be changed 
(  on page 143, Workspace set-
tings). 
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12.2 System properties displays 
You can view the software and hardware properties for weldMARK®: 

Software properties 
o Select the System >Properties... 

option from the menu. 
o Select the Windows tab. 

The adjacent window is opened. 
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Hardware properties   
o Select the System >Properties... 

option from the menu. 
o Select the Hardware devices tab. 

The adjacent window is opened. 
You can view the properties for the 
hardware by opening the associated 
tree view. 
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12.3 Global Settings 
The "Globals..." allow weldMARK® to be adapted to changed external conditions. For exam-
ple, this can be necessary because of a slowly declining laser power or a slight change in the 
position of the objects to be marked. The windows in which these adaptations can be made 
differ at the various access levels. 
 

Globals at the "All editing functions" 
access level 
o Select the System >Globals... 

option from the menu. 
The adjacent window is opened. 
Refer to the table below for expla-
nations. 
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Globals at the "Touchscreen inter-
face" access level 
o Touch the OPTIONS button. 
o Touch the ADJUST button. 

The adjacent window is opened. 
Refer to the table below for ex-
planations. 

S128 

 
 

Laser power % change 

Mark speed % change 

Adapting the laser power or the marking speed affects all marking ob-
jects included in the job. 

X offset 

Y offset 

All objects included in the job are marked offset by the X and Y values 
entered here. 

Apply when application 
starts 

Only available at "All editing functions" access level: 
If this function is enabled, the settings will be saved along with weld-
MARK®. They then apply throughout the system. 
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12.4 System security settings  

12.4.1 Password protection  
weldMARK® provides three access levels, which allow full or limited access to the program's 
functions (  on page 11, Access levels). Changing access level can be protected by a pass-
word. 
 

o Select the System >Security >Change Password 
option from the menu.  
If a password has already been entered, you will 
be prompted to enter it. 

S130

The adjacent window is opened.  
Refer to the table below for explanations. 
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New password 

Confirm password 

Enter the password of your choice in the input boxes. The password can 
consist of any string of characters. 
If you want to disable password protection, do not enter a password. 

12.4.2 Job files for restricted access levels 
At the Operator interface only and Touchscreen interface access levels, you can only load 
jobs that are located in the preset folder. The preset folder when installing weldMARK® can be 
changed (  on page 150, Settings for the job file). All jobs you want to be accessible at the 
restricted access levels must be stored in this folder. 
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12.5 Backing up system settings 
The entries in the operating system registry can be saved in a backup file. This backs up the 
entries or allows them to be transferred to a different weldMARK® system. 

12.5.1 Backing up system settings 
o Select the System >Backup... option from the menu. 
o Select the folder in which you want to save the backup 

file.  
The system settings will be saved in the file 
"system.rbk". 
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12.5.2 Restoring system settings 
Note that the following procedure overwrites all existing system settings in the weldMARK® 
system! 
o Select the System >Restore... option from 

the menu.  
o Browse to the file to be loaded - system.rbk.
o Select the file and click on Open. 

The system settings saved in the backup file 
are loaded. 
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13 CALIBRATING THE MARKING FIELD  
Because of the construction of the X/Y deflection units and the optical properties of F-Theta 
lenses, a distorted marking field is output. Therefore, a specific correction file is provided for 
each deflection unit, which allows the software to compensate for this distortion. Further in-
formation on field distortion can be found in the application manual available from RAYLASE. 

13.1 Correction of mechanical tolerances 
The type-specific field distortion of a deflection unit is compensated for automatically once the 
corresponding weldMARK® correction file has been assigned. However, because of mechani-
cal tolerances every deflection unit can also produce its own individual field distortion. The 
procedures below allow you to compensate for this distortion as well. 

13.1.1 Calibrating the size of the marking field 
o Select the System >Preferences 

option from the menu. 
o Select the Hardware tab.  
o From the directory tree, select the 

lens under the deflection unit you 
want to calibrate. 

o Click on the Calibrate… button. 
o Read and acknowledge the 

confirmation prompt that appears. 
The adjacent window is opened. 

o Click on the Next button. 
The following window is opened. 
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o Select Yes and click on Next.  
The following window is opened. 

S135

 



Calibrating the marking field Chapter 13 

MN013 / v2.0 RAYLASE weldMARK® 159 

o Select the calibration value that you 
want to reset and click on Next. 
The following window is opened. 
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o Place a sufficiently large sample in 

the center of the marking field and 
click on Next. 
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  Warning:  

The next action activates the marking laser. 
The laser beam can cause severe injury to the eyes and the skin. Make sure 
that there are no reflective objects in the beam path before starting a job and 
turning on the laser. Note that even apparently matt objects can reflect the 
wavelength of laser beams. 
All personnel in the room must wear appropriate laser protection goggles, or the 
marking area must be completely covered. Follow the local safety regulations, 
which can be obtained from the person responsible for laser safety. 

 
o Click on the Mark test pattern button.  

The pattern is marked using the test 
pattern settings. 

o Click on the Next button. 
The following window is opened. 
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o Measure the marked test pattern and 
enter the measured width (X 
dimension) and height (Y dimension) 
in the corresponding input boxes. 
Click on the Next button. 
If differing values have been entered, 
the following window is opened. Oth-
erwise, the offset setting screen is 
opened (  on page 161, Calibrating 
the offset). 
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o Place another sufficiently large 
sample in the center of the marking 
field. 

o Click on the Mark test pattern button. 
The pattern is marked using the test 
pattern settings. 

o Click on the Next button. 
The following window is opened. 
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o Measure the marked test pattern. 
o Compare the measured values with 

the target values specified in the 
adjacent window. 

o Depending on the result, click on Yes 
or No in the adjacent window. 

o Click on the Next button. 
Depending on your previous selec-
tion, either calibration is repeated or 
the process continues with the next 
window. 
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13.1.2 Calibrating the offset 
Offset calibration is part of the Calibration Wizard and is offered automatically after size cali-
bration. 
o If you want to perform offset 

calibration, select Yes in the adjacent 
window. 

o Click on the Next button. 
The following window is opened. 
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o Enter the values by which you want 
the marking field to be moved 
horizontally (X axis offset) and 
vertically (Y axis offset). 

o Click on the Next button. 
The following window is opened. 
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o Exit the Calibration Wizard by clicking 
on Done. 
Your entries will be saved. 
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13.1.3 Calibrating the rotation 
Rotation calibration is part of the Calibration Wizard and is offered automatically after an offset 
calibration. 
o If you want to perform a rotation 

calibration, select Yes in the adjacent 
window. 

o Click on button Next. 
The following window is opened. 
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o Select a orientation (0°, 90°, 180°, 
and 270°) for the rough rotation 
direction. 

o Insert a value in field Angle to define 
the exact rotation angle. 

o Click on button Next to finish the 
wizard. 
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13.2 Grid correction  

13.2.1 Using grid correction 
The correction files supplied with weldMARK® contain all the information required to compen-
sate for the field distortion caused by laser deflection units. As this process assumes ideal 
lenses and mirror systems, the following points are not taken into account: 
o All lens systems differ slightly due to production tolerances and thus cause individual 

distortion. 
o The galvanometer scanners are not perfectly linear due to production tolerances. 
 
These differences are normally so slight that they can be ignored for most applications. How-
ever, there are applications in which these tolerances will also need to be compensated for. A 
grid correction program can be used to do this. Based on an existing correction file, the pro-
gram creates a new correction file with its own name, specially tailored for the current lens 
combination. The new correction file can be added to the list of correction files in weldMARK®. 
The procedure for this is described in the next section.  

13.2.2 Adding a correction file  
 

o Select the System >Preferences 
option from the menu. 

o Select the Hardware tab.  
o In the directory tree, click on the 

correction file for the deflection unit 
you want to optimize. 

o Click on the Change button.  
o Read and acknowledge the 

confirmation prompt that appears. 
o Click on the Install New File button. 

The adjacent window is opened. 
o Click on the Next button. 

The following window is opened. 
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o Click on Browse... and select the 
correction file you want to add to the 
list. 

o Click on the Next button. 
The following window is opened. 
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o Enter a name for the new correction 
file (max. 25 characters). 

o Click on the Next button. 
The following window is opened. 
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o Specify the type of focusing system 
used. 

o Click on Next. 
The following window is opened. 
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o Enter the calibration factor in bits/mm.
This value can be obtained from the 
manufacturer of the deflection unit. 

o Click on Next. 
The following window is opened.  
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o Enter the focal distance of the lens 
used. 

o Click on Next. 
The following window is opened. 
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o Enter the input aperture of the 
deflection unit. 
This value can be obtained from the 
manufacturer of the deflection unit. 

o Click on Next. 
The following window is opened. 
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o Exit the wizard by clicking on Done. 

The new correction file is added to the 
list. 
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14 CONNECTING THE LASER  
weldMARK® supports SP-ICE, RLC-USB and RLC-PCI control cards. For details of how to 
connect a laser to the relevant control card, refer to the corresponding control card manual.  

14.1 Configuring a laser driver  
weldMARK® is supplied with drivers for various laser systems. If any changes to the settings 
in these drivers are necessary, the procedure is as follows: 
o Select the System >Preferences 

option from the menu.  
o Select the Hardware tab. 
o In the directory tree, click on the laser 

driver file you want to configure. 
o Click on the Configure… button. 
o Read and acknowledge the 

confirmation prompt that appears. 
The adjacent window is opened. 

o Click on the Next button. 
See the flow diagram on the following 
pages for settings. 
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14.2 Adding a new laser driver  
A laser driver is a file that contains the operating parameters for the laser. This file enables 
weldMARK® to control the laser correctly and to display the accurate laser parameters. 
weldMARK® is supplied with various drivers for standard lasers. If the laser type you want to 
use is not included in the list of available laser driver files, you can add a new driver file: 
o Select the System >Preferences 

option from the menu.  
o Select the Hardware tab. 
o In the directory tree, click on the laser 

driver you want to configure. 
o Click on the Change button. 
o Read and acknowledge the 

confirmation prompt that appears. 
o Click on the Install New Laser... 

button. 
The adjacent window is opened. 

o Click on the Next button. 
The following window is opened. 

S172

 

o Enter a name for the laser driver file 
in the input box.  
This name will appear in the list of 
available laser drivers. 

o Click on the Next button. 
o Continue with the procedure as 

described in the next section:  on 
page 166, Configuring a laser driver. 

S173

 
 



Chapter 14 Connecting the laser 

170 RAYLASE weldMARK® MN013 / v2.0 

14.3 Calibrating the visible pointer 
As a result of wavelength differences between the visible pointer and the marking laser, the 
position of the visible pointer in the marking field does not always correspond exactly to that of 
the marking laser. It is therefore necessary to calibrate the visible pointer. This chapter de-
scribes how to do this.  
 
o If necessary, activate the visible 

pointer in the laser driver (  on page 
166, Configuring a laser driver).  

o Select the System >Preferences 
option from the menu.  

o Select the Hardware tab.  
o Click on the visible pointer in the 

directory tree. 
o Click on the Calibrate button. 

The adjacent window is opened. 
o Click on the Next button. 
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o Place a sufficiently large sample in 
the center of the marking field and 
click on Next. 
The following window is opened. 
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  Warning:  

The next action activates the marking laser. 
The laser beam can cause severe injury to the eyes and the skin. Make sure 
that there are no reflective objects in the beam path before starting a job and 
turning on the laser. Note that even apparently matt objects can reflect the 
wavelength of laser beams. 
All personnel in the room must wear appropriate laser protection goggles, or the 
marking area must be completely covered. Follow the local safety regulations, 
which can be obtained from the person responsible for laser safety. 
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o Click on the Mark test pattern button. 
The pattern is marked using the pa-
rameters set in the test pattern profile. 

o Click on the Next button. 
The following window is opened. 
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o Use the arrow keys to adjust the 
position and size of the test pattern 
shown by the visible pointer. 

o Click on the Next button. 
The following window is opened. 
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o Click on Done to exit the wizard. S178
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15 CONNECTING DEFLECTION UNITS  
weldMARK® uses the XY2-100 protocol to operate deflection units using RAYLASE control 
cards. Deflection units made by other manufacturers can also be used, provided they support 
this protocol. Detailed information on connecting the deflection units to the control cards can 
be found in the manual for the relevant card. 

15.1 Connecting multiple control cards 
weldMARK® can operate with multiple control cards in a computer. Each card can be used to 
operate one laser and one deflection unit. This is only possible with control cards that have 
multi-card capability. With the SP-ICE control card, up to four cards can be installed in a com-
puter. 
Installation of control cards is described in the manuals supplied with them. When weld-
MARK® is started after installing control cards, the program detects the new cards installed 
and shows them in the Job Manager.  

15.2 Connecting multiple deflection units to a control card 
If the SP-ICE control card is used, multiple deflection units and a laser can be connected to a 
single SP-ICE card. Output of the vectors to the individual deflection units is synchronized. 
For details, refer to the manual for the SP-ICE card.  
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16 CONNECTING TO EXTERNAL DEVICES  
weldMARK® supports various I/O interfaces for communicating with external devices. In addi-
tion, weldMARK® can be operated with up to four stepper motor controls. 

16.1 Standard I/O card / Interlock card 
weldMARK® uses the same card type as the standard I/O card and as the interlock card. The 
mode is set by a bridge from GND to the corresponding pin (CARD ID). Depending on the 
mode, this results in one of the following pin assignments: 

 

B107 

B108 

 
Standard I/O card  Interlock card 

 

Signal Explanation  Signal Explanation 

UserI1-4 I  

STEPREPEAT1-2 I  

INTERLOCK1-23 I Trigger  
(>50mS LOW) 

START PROCESS I 

Trigger  
(>50mS LOW) 

    

PROCESS 
ENABLED1-6 

O LOW active     

MARK IN 
PROGRESS 

O LOW during marking     

ERROR FLAG O LOW on error     

USEROUT1-6 O Programmable     

BUSY/READY O Programmable     

I = Input, O = Output 
 
All inputs and outputs are TTL connected and have a pull-up resistance of 2.2kΩ. The ports 
must be electrically isolated from the connected hardware. Electrical interference pulses must 
be prevented as far as possible. If relays are used, they must be fitted with diodes. The con-
necting cables must be shielded and kept as short as possible, and the shield must be con-
nected to the computer housing. 

I/O card 
The optional standard I/O card allows job sequences to be controlled by external signals using 
automation objects. In addition, weldMARK® can use automation objects to output control 
signals to operate external components. 
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Interlock card 
The optional interlock card enables weldMARK® to respond to interlock signals from external 
components. Each of the interlock inputs (INTERLOCK1 to INTERLOCK23) can be config-
ured as HIGH or LOW when active. This configuration is carried out in the file "\Program 
Files\raylase\weldmark\bin\intmsg.txt", as shown below. 
 
Interlock Messages 
[ASSERTION] 
AssertLevel0=0 
AssertLevel1=0 
AssertLevel2=0 
AssertLevel3=0 
AssertLevel4=0 
AssertLevel5=0 
AssertLevel6=0 
AssertLevel7=0 
AssertLevel8=0 
AssertLevel9=0 
AssertLevel10=0 
AssertLevel11=0 
AssertLevel12=0 
AssertLevel13=0 
AssertLevel14=0 
AssertLevel15=0 
AssertLevel16=0 
AssertLevel17=0 
AssertLevel18=0 
AssertLevel19=0 
AssertLevel20=0 
AssertLevel21=0 
AssertLevel22=0 

 AssertLevel22=0 
[MESSAGE] 
Msg0=Interlock 1 error ! 
Msg1=Interlock 2 error ! 
Msg2=Interlock 3 error ! 
Msg3=Interlock 4 error ! 
Msg4=Interlock 5 error ! 
Msg5=Interlock 6 error ! 
Msg6=Interlock 7 error ! 
Msg7=Interlock 8 error ! 
Msg8=Interlock 9 error ! 
Msg9=Interlock 10 error ! 
Msg10=Interlock 11 error ! 
Msg11=Interlock 12 error ! 
Msg12=Interlock 13 error ! 
Msg13=Interlock 14 error ! 
Msg14=Interlock 15 error ! 
Msg15=Interlock 16 error ! 
Msg16=Interlock 17 error ! 
Msg17=Interlock 18 error ! 
Msg18=Interlock 19 error ! 
Msg19=Interlock 20 error ! 
Msg20=Interlock 21 error ! 
Msg21=Interlock 22 error ! 
Msg22=Interlock 23 error ! 

 
In the lines AssertLEVEL0 to AssertLEVEL22, the active status of each interlock input can be 
set to "0" or "1". 
Each interlock input is assigned a name using the lines Msg0-Msg22. This name is displayed 
by weldMARK® if there is a corresponding interlock event. 
In some situations, it may be necessary to use different interlock names and AssertLevels for 
different laser types. weldMARK® supports this function by linking the interlock configuration 
file with the laser driver file. Please contact RAYLASE for further details.  
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16.2 Operating stepper motors 
weldMARK® can be operated with up to four stepper motor controls. For example, this allows 
an XY table, a Z axis and a rotary axis to be controlled. 

16.2.1 Installing the Plug&Play drivers in Windows 2000, Windows XP 
The card for operating stepper motors must be installed in your computer. 
o Start the computer. 

Windows detects the new 
hardware and starts the 
wizard for installing the driver 
files. 

o Click on the Browse button. 
o Select the directory 

…\Program Files\raylase\ 
weldmark\oms. 

o Click on the Next button. 
Windows installs the OMS 
driver. 

S206S 

16.2.2 Configuring the motor control settings 
o Select the System >Preferences 

option from the menu.  
o Select the Motor Control tab.  

The adjacent window is opened. 
o Edit the settings as described in the 

next section. 
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Editing the motor settings  
The settings for the stepper motor control determine the default speed, the default accelera-
tion and the functions for moving the individual axes and moving to the home position. 
o Select the System >Preferences 

option from the menu.  
o Select the Motor Control tab.  
o Click on the Properties button. 
o Select the Controller Settings tab. 

The adjacent window is opened. 
The displayed values are default 
settings used with motorized linear 
translator.  
Refer to the table below for expla-
nations. 

? 

 

Current axis This list box can be used to select the required axis. 

Base 

Default Maxi-
mum 

Velocity 

Default Minimum 

These input boxes can be used to determine the basic, maxi-
mum and minimum speed of the stepper motor. 

Ramp 

Maximum 

Acceleration 

Ramp steps 

These input boxes can be used to determine the acceleration 
characteristics, the maximum acceleration and the number of 
acceleration steps. 

Invert direction 
bit 

If this function is enabled, the direction of movement is in-
verted. 

Limits are active 
high 

If this function is enabled, the status of the limit switch is set to 
active LOW to active HIGH. 

Enable over-
travel detection 

If this function is enabled, the limit switches are monitored dur-
ing movement. 

Axis Travel 

Enable soft travel 
limits  

If both the Enable overtravel detection function and this func-
tion are enabled, the control card stops the axis when a limit 
switch is detected. 

At home when Status of the limit switch when the home position is reached. Homing 

Direction Direction of travel of the movement unit when searching for the 
home position. 

Absolute For destinations, the co-ordinates to which you want the 
movement unit to move are specified. 

Moves are 

Relative For destinations, the distances by which you want the move-
ment unit to move are specified. 
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Editing the settings for the XY table 
o Select the System >Preferences 

option from the menu.  
o Select the Motor Control tab.  
o Click on the Properties button. 
o Select the XY Table tab.  
o Make the required changes.  

The adjacent window is opened.  
Refer to the table below for expla-
nations. 

 

 

(1) This check box can be used to activate the movement unit. The corresponding functions in 
the program interface are then available. 

Axis Name These text boxes can be used to specify the name for the movement unit X 
and Y-axes. The names are then used in the corresponding dialogs in the 
program interface. 

Cal factor Calibration factor for the axes in steps per millimeter. 

Home  Clicking on this button returns the movement unit to its home position. The 
home position is defined in the field to the right of the Home button. 

Fwd  

Rev 

Clicking on these buttons determines the limit switch position. As soon as 
the movement unit arrives at the limit switch, the position is saved and dis-
played. This information allows the user to be notified of the physical 
boundaries in the program sequence. 

Timeout  A time can be entered in this field. If a limit switch is not found before this 
time has elapsed, the movement unit stops as a precaution. 

Clicking on this button allows the movement unit to be moved with the fol-
lowing parameters for testing purposes: 

Move to This field can be used to specify the position to which the XY 
table moves when you click on the GO button. 

Go 

At speed This field can be used to specify the speed at which the XY 
table moves when you click on the GO button. 

 

Stop Clicking on this button stops movement of the motor immediately. 

Absolute For destinations, the co-ordinates to which you want the movement unit to 
move are specified. 

Moves 
are 

Relative For destinations, the distances by which you want the movement unit to 
move are specified. 
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Editing the settings for the Z-axis (laser lift or Lens Translator)  
o Select the System >Preferences 

option from the menu.  
o Select the Motor Control tab.  
o Click on the Properties button.  
o Select the Custom Axis tab.  
o The adjacent window is opened. 

The displayed values are default 
settings for motorized linear 
translator. 
Refer to the table below for 
explanations. 

s 

 

 

(1) This check box can be used to activate the movement unit. The corresponding functions in 
the program interface are then available. 

Z Axis 
Name 

This text box can be used to specify the name of the motion unit Z-axis. The 
name is then used in the corresponding dialogs in the program interface. 

Rotary Display 
Settings 

Linear 

These check boxes specify whether you want to operate a ro-
tary or linear axis.  

Cal factor Calibration factor for the axis in steps per millimeter. 

Home  Clicking on this button returns the movement unit to its home position. The 
home position is defined in the field to the right of the Home button. 

Fwd  

Rev 

Clicking on these buttons determines the limit switch position. As soon as 
the movement unit arrives at the limit switch, the position is saved and dis-
played. This information allows the user to be notified of the physical 
boundaries in the program sequence. 

Timeout  A time can be entered in this field. If a limit switch is not found before this 
time has elapsed, the movement unit stops as a precaution. 

Clicking on this button allows the movement unit to be moved with the fol-
lowing parameters for testing purposes: 

Move to This field can be used to specify the position to which the Z 
table moves when you click on the GO button. 

Go 

At speed This field can be used to specify the speed at which the Z table 
moves when you click on the GO button. 

 

Stop Clicking on this button stops movement of the motor immediately. 

Absolute For destinations, the co-ordinates to which you want the movement unit to 
move are specified. 

Moves 
are 

Relative For destinations, the distances by which you want the movement unit to 
move are specified. 
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Editing the settings for the rotary axis (indexer)  
o Select the System >Preferences 

option from the menu.  
o Select the Motor Control tab.  
o Click on the Properties button. 
o Select the Rotary tab.  
o The adjacent window is opened.  

Refer to the table below for 
explanations. 

s 

 

 

(1) This check box can be used to activate the movement unit. The corresponding functions in 
the program interface are then available. 

T Axis 
Name 

This text box can be used to specify the name of the motion unit rotary axis. 
The name is then used in the corresponding dialogs in the program inter-
face. 

Display 
Settings 

Cal factor Calibration factor for the axis in steps per millimeter. 

Home  Clicking on this button returns the movement unit to its home position. The 
home position is defined in the field to the right of the Home button. 

Fwd  

Rev 

Clicking on these buttons determines the limit switch position. As soon as 
the movement unit arrives at the limit switch, the position is saved and dis-
played. This information allows the user to be notified of the physical 
boundaries in the program sequence. 

Timeout  A time can be entered in this field. If a limit switch is not found before this 
time has elapsed, the movement unit stops as a precaution. 

Clicking on this button allows the movement unit to be moved with the fol-
lowing parameters for testing purposes: 

Move to In this field, you can specify the position to which the motion 
unit moves when you click on the GO button. 

Go 

At speed In this field, you can specify the speed at which the motion unit 
moves when you click on the GO button. 

 

Stop Clicking on this button stops movement of the motor immediately. 

Absolute For destinations, the co-ordinates to which you want the movement unit to 
move are specified. 

Moves 
are 

Relative For destinations, the distances by which you want the movement unit to 
move are specified. 
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 Stepper motor control properties  
o Select the System >Preferences 

option from the menu.  
o Select the Motor Control tab.  
o Click on the Properties button. 
o Select the Card Properties tab. 

The adjacent window is opened. 
This window shows the stepper 
motor control properties. 

s 
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16.3 Remote interface  
The remote interface enables weldMARK® to be controlled using a remote program. The ex-
ternal program can run jobs, dynamically change the content of marking objects and execute 
jobs. After executing each command, weldMARK® sends a response to the remote program.  
While weldMARK® is being controlled by the remote program, the normal weldMARK® user 
interface is blocked to prevent the user from intervening in processes that are in progress. 
Detailed information about the remote interface can be found in the weldMARK® Remote In-
terface manual. 
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17 APPENDIX: TCP/IP TEST CLIENT  
The TCP/IP test client is a tool for testing the remote interface functionality. For further infor-
mation about the remote interface refer to the corresponding manual. This is available sepa-
rately from RAYLASE.  

Starting the TCP/IP test client 
o Start the program tcptestclient.exe, located in the 

directory …\Program Files\raylase \weldmark\bin. 
o If the TCP/IP test client is running on the same 

computer as weldMARK®, enter the  
IP address "127.0.0.1". 
If the TCP/IP test client is running on a different 
(remote) computer, you must enter the IP address 
of the computer on which weldMARK® is running in 
the Addr. field. 

o In the Port field, enter the value "350": 
o Make sure that weldMARK® is running on the local 

computer or on the remote computer. 
o Click on the Connect button.  

The TCP/IP test client connects to the weldMARK® 
instance and is ready to exchange data with 
weldMARK®.  

S203s

 

Example: 
Note: For this example, weldMARK® must be configured in such a way that the program will 
accept commands from the TCP/IP port. Detailed information can be found in the remote in-
terface manual. 
o Enter the following command lines (with variations 

on meaning), and send each line with the button 
Send >>>.  

 SET,control,host 
 OPEN,file,c:\Ts00t.wmj 
 RUN 
 MODIFY,filed,01,123456 
 OFFLINE 
 SET,control,local 

s 
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